Search Issue Tracker

Postponed means that the issue was either a feature request or something that requires major refactoring on our side. Since that makes the issue not actionable in the close future we choose to close it as Postponed and add it on our internal roadmaps and technical debt pages instead.

Postponed

Votes

7

Found in

5.3.0b3

Issue ID

737294

Regression

No

UI Text disappears on editor focus change due to editor DLL

UI

-

How to reproduce:
1. Open provided example project
2. Open Assets/TestScene.unity
3. Double-click "HUD" game object to bring it into view
4. Notice it displays "Hello World" and select Text
5. Open other program
6. Switch back from that program to Unity and hover with mouse on top of the text
=> Notice the text "Hello World" in the Scene View disappears
7. Select Canvas and Text, then hover again
=> Text will reappear

Similar behavior when minimizing Unity, only then not Text but Canvas should be selected.
Also with different QWERT buttons it is slightly different. When doing step 6 with Q and T it is enough to hover, with WER you need to click on the scene view.

Comments (14)

  1. 933bde7635092fa5b67bd5eb6d3d517c?d=mm

    F3R0Ci0U5XX88

    Feb 11, 2019 15:55

    Hey guys I know this won’t fix it for everyone, but give it a try cause it was my issue.. super dumb little thing. So my text was always there, perfect, fine. Didn’t touch it, and one day it was gone. Found my solution. For some reason the bounding box was sized down at some point, and I changed my text size down a digit. Voila. Hope this solves it for someone else!

  2. De3d107ed1ccad362b44763106a78178?d=mm

    JeromeJ

    Apr 06, 2018 21:30

    Postponed… To when though?

  3. 6116d1a4ac7a7e0ad87d5472c256369e?d=mm

    cheonganlee

    Mar 31, 2018 01:44

    Please fix this. It should be easy to fix this.

  4. 2e299bdecca0a523601e6a83ddbcf151?d=mm

    Berd

    Feb 02, 2018 10:14

    Commenting to vent my frustration, as voting is disabled.

  5. 02c288738b5e9eb816404bfd348d080e?d=mm

    spilat12

    Jan 13, 2018 21:03

    Meanwhile, in 2018... The issue still persists.

  6. 1ed7298c1e3bd188e0d4d0bc021187e0?d=mm

    zephlabs

    Dec 22, 2017 18:48

    Can't believe this is still a problem. So frustrating to work with unity UI. it's sooo close to great!

  7. 88b88489034b87444cc50feaa38d9596?d=mm

    Nyasaki

    Dec 18, 2017 19:26

    Same here

  8. D6f94df89007aec5fbe02deb6d65728d?d=mm

    DeadShawn

    Nov 08, 2017 05:06

    I have this happening in my build (Win32) as well as the editor. Seems to happen when users alt+tab.

  9. 7e663aa93df808a4498116cb43f75778?d=mm

    Zarod

    Oct 01, 2017 10:32

    lol, still happening ... I don't mind, the moving UI workaround, it's ok ... at least i'm sure there's a use for those scripts

  10. 9dcc67f444e11c11c4d4823c8ad2d6fc?d=mm

    jwvanderbeck

    May 21, 2017 14:54

    Totally not resolved! It happens in 5.6f03 and not just when the editor loses focus, but also just whenever I middle mouse drag to pan the scene view!

    It makes working with the UI practically impossible.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.