Search Issue Tracker

Fixed in Unity 5.5.0

Votes

0

Found in

5.3.3p1

Issue ID

776003

Regression

No

The WWW and UnityWebRequest classes currently don't support HTTPS TLS 1.2 on Android versions prior to 5.0

Android

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Secondary functionality broken

Reproduction steps:
1. Open the attached project
2. Build and run the project on Android device with Android versions prior to 5.0 (e.g. Android 4.4.2)
3. Press on the "UnityWebRequest" or "WWW Request" button
4. Notice that errors are thrown (check logcat)

Expected result: Content should be pulled from the server. In this case a word "banana".

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.