Search Issue Tracker

Fixed in 2017.2.0f3



Found in


Issue ID




[Android] Project fails to build using the updated Android SDK Tools 26.0 during the merging manifest files



Reproduction steps:
1. Update Android SDK Tools to 26.0.1 or 26.0.2;
- Android Studio -> Configure -> SDK Manager -> Android SDK -> SDK Tools
2. Create the new project;
3. Switch the platform to Android in the Build settings;
4. Enable "Virtual Reality Supported" and select VR SDKs (Oculus or Daydream) in the Player settings;
5. Build the project;

Actual result: the project does not build and the window "Build failure" shows up with an error "Unable to merge android manifests" (build_failure.jpg).
Expected result: the project should be built on Android platform.

Note: the issue happens only when Android SDK Tools is updated to 26.0, because when it is 25.2.5 version, everything works fine. Also, if "Virtual Reality Supported" is disabled, everything works correctly too.

Reproduced with: 5.4.5p2, 5.5.3p3, 5.6.0p4, 2017.1.0b4

Samsung SM G928F*, OS:6.0.1, CPU:arm64-v8a, GPU:Mali-T760, Build:samsung/zenltexx/zenlte:6.0.1/MMB29K/G928FXXS3BPIA:user/release-keys (Reproduced)

Sony D6603 (Xperia Z3)*, OS:6.0.1, CPU:armeabi-v7a, GPU:Adreno (TM) 330, Build:Sony/D6603/D6603:6.0.1/23.5.A.1.291/2769308465:user/release-keys (Reproduced)

Samsung SM G361F*, OS:5.1.1, CPU:armeabi-v7a, GPU:Vivante GC7000UL, Build:samsung/coreprimeveltexx/coreprimevelte:5.1.1/LMY48B/G361FXXU1APB1:user/release-keys (Reproduced)

Merging for Daydram fixed in:
5.4.5p3, 5.5.3p4, 5.6.0p4, 2017.1.0b3

Fix for Oculus coming soon, this will be edited to reflect the changes.

Comments (26)

  1. madhawk77

    Nov 11, 2017 13:24

    Still no official fix for this from Unity?

  2. davidosullivan

    Oct 18, 2017 22:33

    I get this in 2017.1.2p1 and I cant upgrade to 2017.2 because 2017.2 *reintroduces* an issue with mesh combiner- that was fixed eventually in 2017.1 -that stops UMA from working. So please release another patch for 2017.1, or better yet, when you release a new version of Unity, please include all the fixes that you made in the previous versions!

  3. Samantha_Jones

    Jul 26, 2017 10:57

    The issue has been resolved, though the oculus fix isn't available and there appears to be no workaround since previous Android tools are no longer available from the website

  4. monremobile

    Jul 13, 2017 21:31

    This works for me:

    Download BuildTools 25.0.3 and 26.0.0
    Copy and paste apksigner.bat from 25 to 26
    Copy and paste lib/apksigner.jar from 25 to 26

    ... fixed! :)

  5. idontneedthat

    Jul 13, 2017 14:37

  6. OmarAbdelhafiz

    Jul 10, 2017 17:45

    For me downgrading to revision 25.2.5 worked just fine. Once you download an older version of the tools, if you have android studio installed put these tools in a directory different from the Android SDK directory, then just install the Android SDK Tools, Android SDK Platform-tools, Android SDK Build-tools, the latest API level as described in the tutorial.

    Here are the links:


    Mac OSX:

  7. HamzaKhan1

    Jun 30, 2017 22:38

    @JAZZPABLO My Oculus Signature File does not work, when I build the game and insert the phone into the gearVR it says add signature file to APK

  8. barceloco

    Jun 28, 2017 00:25

    I've had the same problem. Thanks for reporting!

  9. Brainversation01

    Jun 12, 2017 21:08

    @JAZZPABLO Thank you soooooo much!!!

  10. DavidSmit

    Jun 09, 2017 15:10

    Update, this seemed to work: (I couldn't find the files there, but a quick google will get you the right file)

    1) just open
    2) scroll down to the bottom of that page
    3) go to downloads
    4) scroll down to the bottom of that page
    5) find Windows "" download and unzip it
    5) find MacOSX "" download and unzip it.
    6) In the SDK path replace the tools folder.

    as related in this issue thread:

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.