Search Issue Tracker

Fixed in Unity 2017.2

Votes

37

Found in

5.6.0p3

Issue ID

907071

Regression

No

[Android] Project fails to build using the updated Android SDK Tools 26.0 during the merging manifest files

Android

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 2No workaround

Reproduction steps:
1. Update Android SDK Tools to 26.0.1 or 26.0.2;
- Android Studio -> Configure -> SDK Manager -> Android SDK -> SDK Tools
2. Create the new project;
3. Switch the platform to Android in the Build settings;
4. Enable "Virtual Reality Supported" and select VR SDKs (Oculus or Daydream) in the Player settings;
5. Build the project;

Actual result: the project does not build and the window "Build failure" shows up with an error "Unable to merge android manifests" (build_failure.jpg).
Expected result: the project should be built on Android platform.

Note: the issue happens only when Android SDK Tools is updated to 26.0, because when it is 25.2.5 version, everything works fine. Also, if "Virtual Reality Supported" is disabled, everything works correctly too.

Reproduced with: 5.4.5p2, 5.5.3p3, 5.6.0p4, 2017.1.0b4

DUT:
Samsung SM G928F*, OS:6.0.1, CPU:arm64-v8a, GPU:Mali-T760, Build:samsung/zenltexx/zenlte:6.0.1/MMB29K/G928FXXS3BPIA:user/release-keys (Reproduced)

Sony D6603 (Xperia Z3)*, OS:6.0.1, CPU:armeabi-v7a, GPU:Adreno (TM) 330, Build:Sony/D6603/D6603:6.0.1/23.5.A.1.291/2769308465:user/release-keys (Reproduced)

Samsung SM G361F*, OS:5.1.1, CPU:armeabi-v7a, GPU:Vivante GC7000UL, Build:samsung/coreprimeveltexx/coreprimevelte:5.1.1/LMY48B/G361FXXU1APB1:user/release-keys (Reproduced)

Merging for Daydram fixed in:
5.4.5p3, 5.5.3p4, 5.6.0p4, 2017.1.0b3

Fix for Oculus coming soon, this will be edited to reflect the changes.

Comments (23)

  1. D1738665e6a05b68159d278c89807267?d=mm

    pesahov

    Feb 20, 2018 16:38

    It's working with Tools 26.1.1 on Unity 2017.3.p1

  2. 92faa9f5d007dd90f356c79f4e2bd009?d=mm

    ethans

    Feb 02, 2018 19:37

    Not fixed in the latest versions 2017.2 and 2017.3, I'm using Windows 10 x64 with JDK 1.8 and I've tried with Android SDK versions 20 to 27. It is such a drag having to waste hours on hours fixing something as simple building your app!

    The only solution I've found is reverting back to Unity 5.3 and using an old version of the Oculus and OpenVR packages.

  3. 1dad50e3563abe4f847a4fe34077afba?d=mm

    ACHIEVR

    Jan 21, 2018 22:33

    Very frustrating. So far lost almost a day just trying to build a basic GearVR apk.

  4. 6b258020cee51581ac63db2d6b853c60?d=mm

    Shane8th

    Jan 17, 2018 15:13

    This is not fixed in 2017.3.0f3.

  5. E702d59da62838d32ad10da1315fe6b4?d=mm

    Olavii

    Jan 13, 2018 14:35

    Still not fixed in 2017.2, 2017.3, or 2018 beta

  6. D9f8af99ad37af0878f4de2e2cae283b?d=mm

    sqsezs

    Jan 02, 2018 12:48

    still not fixed 2017.2.0f3

  7. 3484b7c34fc943a2d4ef24d5a874cbce?d=mm

    MyrDovg

    Nov 28, 2017 16:34

    Still is not fixed in 2017.2.0p2

  8. 93a619408b743355f109db1612929cd5?d=mm

    madhawk77

    Nov 11, 2017 13:24

    Still no official fix for this from Unity?

  9. 8265ed728f9082fadaae67772d4a3557?d=mm

    davidosullivan

    Oct 18, 2017 22:33

    I get this in 2017.1.2p1 and I cant upgrade to 2017.2 because 2017.2 *reintroduces* an issue with mesh combiner- that was fixed eventually in 2017.1 -that stops UMA from working. So please release another patch for 2017.1, or better yet, when you release a new version of Unity, please include all the fixes that you made in the previous versions!

  10. 9b855e653cc2fa6fe3d99878b34c8eca?d=mm

    Samantha_Jones

    Jul 26, 2017 10:57

    The issue has been resolved, though the oculus fix isn't available and there appears to be no workaround since previous Android tools are no longer available from the website

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.