Search Issue Tracker

Fixed in 2021.2.X



Found in



Issue ID




[Serialization] Different serialization layout error thrown at runtime when Magic Leap XR Plugin is present in the build



How to reproduce:
1. Open the attached Unity project ("")
2. Build And Run
3. When the app finishes loading, observe the output in the Xcode console

Expected result: UnityEngine.XR.MagicLeap.MagicLeapSettings different serialization layout error is not thrown
Actual result: UnityEngine.XR.MagicLeap.MagicLeapSettings different serialization layout error is thrown

Reproducible with: 2021.2.0b7, 2021.2.0b9, 2022.1.0a1
Not reproducible with: 2019.4.29f1, 2020.3.17f1, 2021.1.18f1, 2021.2.0b6, 2022.1.0a2, 2022.1.0a6

Reproducible on:
Phone 8 Plus (iOS 14.4.2)
iPad 6th generation (iOS 14.4.2)
iPad Air 2 (iOS 11.0.3)

VLNQA00288, Samsung Galaxy J7 (SM-J730F), Android 8.1.0, CPU: Exynos 7 Octa 7870, GPU: Mali-T830
VLNQA00022, Xiaomi Redmi Note 3 (Redmi Note 3), Android 6.0.1, CPU: Snapdragon 617 MSM8952, GPU: Adreno (TM) 510
N/A, Huawei - (NOH-NX9), Android 10, CPU: NOT FOUND, GPU: Mali-G78
VLNQA00001, Google Pixel 2 (Pixel 2), Android 11, CPU: Snapdragon 835 MSM8998, GPU: Adreno (TM) 540
VLNQA00316, Samsung Galaxy Note10 (SM-N970F), Android 9, CPU: Exynos 9 Series 9825, GPU: Mali-G76

- On Android, reproducible with IL2CPP Scripting Backend
- On a macOS build, reproducible both with Mono and IL2CPP Scripting Backends

The referenced script on this Behaviour (Game Object '<null>') is missing!
A scripted object (probably UnityEngine.XR.MagicLeap.MagicLeapSettings?) has a different serialization layout when loading. (Read 52 bytes but expected 76 bytes)
Did you #ifdef UNITY_EDITOR a section of your serialized properties in any of your scripts?

  1. Resolution Note (fix version 2021.2):

    Fixed in: 2022.1.0a2

Comments (4)

  1. Ardito92ITA

    Apr 06, 2024 12:00

    Same error in: Unity 2022.3.23f1

  2. konsti1994

    Jun 04, 2023 18:27

    same error in 2021.3.25f1

  3. unity_40771217h

    Apr 09, 2023 12:18

    still encounter this issue in 2022.1.23f1

  4. ProtagonistKun

    Oct 07, 2022 13:18

    Encountering this issue in 2022.1.19f1 as well as 2021.3.9f1.
    Resolution note saying fixed in 2022.1.0a2 seems odd.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.