Search Issue Tracker

Fixed in 5.2.3

Votes

2

Found in

5.2.0b4

Issue ID

714050

Regression

Yes

Realtime GI file not found errors displayed when upgrading project to Unity 5.2

Global Illumination

-

Open attached project in Unity 5.2 and you will get lots of errors like:
Failed opening GI file: 'b2/b2d0e671c9df0fff370993e25d0ff60c.vis'.
Failed opening GI file: 'b2/b2d0e671c9df0fff370993e25d0ff60c.rsc.sse'.
Failed loading system data for hash: 0xb2d0e671c9df0fff370993e25d0ff60c

Opening the project in Unity 5.1 first, doesn't give any of these errors, it's only when imported in Unity 5.2

Comments (24)

  1. Fd8ca45f3afeff0b254b558a9686d910?d=mm

    Akio Sensei

    Dec 23, 2015 08:12

    Unity 5.2.3 didn't fix this issue.

    Still same issues on Unity 5.2.3 and Unity 5.2.4.

    Failed opening GI file: 'de/de4b135f3c10edbcc29ab75ef30c5694.rpc.sse'.

    Failed loading probe set data for hash: 0xde4b135f3c10edbcc29ab75ef30c5694
    UnityEditor.HostView:OnGUI()

  2. 647ab3f358dd867d5f31d2edba4e8aac?d=mm

    November

    Nov 30, 2015 11:52

    I have (probably) the same issue in 5.2.3f1.

  3. 3f04670a91f009460f8d23c83574df54?d=mm

    KEngelstoft

    Oct 30, 2015 10:07

    GI data is not shared among users, even when the Unity cache server is in use. We are looking into the file not found issue.

  4. F5d8df52978a6dace4c0732ad2d104c5?d=mm

    yoyo

    Oct 27, 2015 05:22

    Joachim says "data is cached in your specific GI cache, which is per machine" - is it possible that this lighting data is being incorrectly shared among users when the Unity cache server is in use?

    We are getting errors like this one - http://issuetracker.unity3d.com/issues/gi-data-errors-are-produced-when-attempting-to-build-the-player - when we build with 5.2.1 or 5.2.2. When we build with 5.2.0 the build is successful. And when the user who bakes the lighting data does a local build with 5.2.1 it is also successful.

  5. 6ae1d4d5ac66fcd0bd46b1728c361b64?d=mm

    batate

    Oct 16, 2015 11:27

    I don't think this is fixed... or there are related issues. I had none of the "Failed to add the asset file size for GI/mainData/..." in my project or when doing builds for the web player or a standalone for Oculus Rift... BUT... I just updated from 5.2.0f3 to 5.2.1f1 and now I get 7 of these warnings... e.g. here are two examples...

    Failed to add the asset file size for GI/mainData/38/38cd08f8c12aea0f024903e5ed2d7219.rsc.sse
    UnityEditor.HostView:OnGUI()

    Failed to add the asset file size for GI/mainData/38/38cd08f8c12aea0f024903e5ed2d7219.iws.sse
    UnityEditor.HostView:OnGUI()

  6. F5d8df52978a6dace4c0732ad2d104c5?d=mm

    yoyo

    Oct 14, 2015 16:35

    Still getting this in 5.2.1p3. We use baked light probes, but not light maps. We regularly get these two errors on scene load:
    Failed opening GI file: 'ca/ca31d6b4d59f279464e8f93b78ffaf72.rpc.sse'.
    (Filename: C:/buildslave/unity/build/Runtime/GI/HashFile.cpp Line: 175)

    Failed loading probe set data for hash: 0xca31d6b4d59f279464e8f93b78ffaf72
    (Filename: C:/buildslave/unity/build/Runtime/GI/Enlighten/EnlightenRuntimeManager.cpp Line: 1531)

  7. Dfdb8838271821d988f2c0d5d1234985?d=mm

    Joachim_Ante

    Oct 06, 2015 14:43

    I have looked at the bug in question. It is important to note that there was some version of unity where the lightmap asset was not writing out the enlighten data in some situations.

    So if you do get the error message:
    "Lightmap snapshot '%s' is inconsistent - %i files out of %i are missing. Realtime GI will be disabled. Please rebuild lighting for this scene.", this->GetName (), missingFilesCount, hashFiles.size ()), this);

    Then thats exactly what you need to do. You need to actually rebuild the lightmap snapshot.
    The only reason it worked is because the data is cached in your specific GI cache, which is per machine, so other users would not be able to load the corrupted lightmap snapshot.

  8. 3814800d75f98b311cceefd42b96dd72?d=mm

    vilcans

    Oct 02, 2015 12:38

    It's not fixed in 5.2.1f1, but recreating the lightmaps got rid of the problem.

  9. 6e6adbf3ba3302d5ceffcc7b41c0aa98?d=mm

    BernieZQ

    Sep 29, 2015 10:09

    Still get error when scene was loaded from assetbundle

  10. 04c5428eb72cadae81285f783d3d9d0c?d=mm

    mslinklater

    Sep 28, 2015 12:35

    Still getting this with 5.2.1p1

    The issue isn't fixed guys... 8(

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.