Search Issue Tracker

Won't Fix



Found in





Issue ID




[Quest] Stutter/Frame Pacing with OculusRuntime.WaitToBeginFrame when the Player is built



Reproduction steps:
1. Open the attached project "FramePacingBug"
2. Open “File > Build Settings”
3. Switch platform to the Android
4. Tick Developer Build
5. Tick Autoconnect Profiler
6. Tick Deep Profiling Support
7. Build And Run
8. Observe the built Scene and the Profiler window

Expected result: The Scene is running without stutters and no spikes appear in the Profiler window
Actual result: The Scene is stuttering with spikes seen in the Profiler window

Reproducible with: 2022.2.6f1, 2023.1.0b3, 2023.2.0a1
Could not test with: 2020.3.45f1. 2021.3.18f1 (com.unity.ugui@1.0.0\Runtime\UI\Core\Toggle.cs(162,33): error CS0115: 'Toggle.OnDidApplyAnimationProperties())

Reproducible with devices:
VLNQA00379, Oculus (Quest 2), Android 10, CPU: Snapdragon XR2, GPU: Adreno (TM) 650

Reproducible on: Windows 10 Enterprise 21H2

* The issue is only noticeable on Quest VR builds. With Steam VR the issue does not appear present
* The user started to experience stutters after upgrading the project from Unity 2020.3.4 (URP 10.4.0) to Unity 2021.3.10 (URP 12.1.7)
* We’ve been able to reduce the issue by switching to 72hz. But there is still a stutter every one to two seconds. We’ve discovered that if we try to change the refresh rate with the OVRManager call the issue will get worse until the headset is put to sleep and woken back up.
* When running with the profiler the issue gets worse and the spikes are OculusRuntime.WaitToBeginFrame. Everything else in the game is well below 10ms.
* What We’ve tried and hasn’t had an impact
-Upgrading the Oculus Integration 3.2.2 (Package Manager)
-Upgrading the Oculus SDK to v47 (Asset Store)
-Switched Oculus to use the OpenXR back end
-Tested on OpenGLES and Vulkan
-Test builds with Late Latching, Phase Sync, and Optimized Frame Pacing




  1. Resolution Note:

    We were unable to recreate this issue on Quest 2 and Quest 3 with versions 2022.3 and 2023.3.
    If you think that it is still an important problem to solve please re-open and provide more information.

Comments (11)

  1. jtpistella

    Aug 28, 2023 16:06

    Issue still occurring on 2022.3.5f1. Crossing fingers for a fix soon!

  2. LizNT

    Aug 28, 2023 16:06

    Running into this issue in 2022.3.5f1, hoping to get a fix soon!!

  3. unity_D8437A28F4A1412DDD37

    Aug 28, 2023 16:05

    Still seeing this issue on 2022.3.5f1. Still easy to repro.

  4. mblt2334

    May 25, 2023 17:50

    I am having this issue with 2021 LTS as well. Really hoping for a fix soon!

  5. leftClaw

    Apr 15, 2023 22:54

    We could really use a fix for this on 2021.3.LTS as well, would be a lot of work and risky to update to 2022 just for this

  6. Eclectus

    Mar 20, 2023 22:15

    A fix for this in 2021.3.x would be great

  7. ScottJustScott

    Feb 24, 2023 21:15

    Please also consider for 2021.3. I've definitely reproduced this issue there and it's what the main forum this bug submission came from was using. I've also personally reproduced this very bug submission in 2021.3. No idea why QA was getting some Toggle.cs errors in 2021, but it seems unrelated.

  8. mxweas

    Feb 22, 2023 18:14

    It's worth noting that we updated URP 10.9 to work on Unity 2022.2 and the issue went away for us. It seems to be URP related.


  9. DevDunk

    Feb 21, 2023 16:15

    Also reported on 2021.3.19f1

  10. ChescoRed

    Feb 21, 2023 15:07

    I'm running into the same problem, only using URP in Unity version 2021.3.18f, I've already tried with older versions 16f and 17f.

    It also occurs with App Space Warp.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.