Search Issue Tracker

Fixed in 2020.2.X

Fixed in 2019.3.X, 2020.1.X

Votes

89

Found in

2019.3.0f6

2020.1.0a20

Issue ID

1215431

Regression

Yes

NullReferenceException is thrown when inspecting a .FBX file with multiple clips and opening Animation tab

Asset Importers

-

How to reproduce:
1. Open the attached 'project-1215431.zip' project
2. In the Project window select 'MultiClipSingleFile'
3. Observe the Console window
4. In the Inspector select 'Animation' tab
5. Observe the Console window

Expected result: NullReferenceExceptions are spammed in the Console window, the asset is broken
Actual result: No exceptions are thrown in the Console window, the asset is not broken

Reproducible with: 2019.3.0f6, 2020.1.0a20, 2020.1.0a21
Not reproducible with: 2017.4.36f1, 2018.4.16f1, 2019.2.20f1, 2019.3.0f5, 2020.1.0a1, 2020.1.0a19

Thrown exceptions:
1) NullReferenceException: Object reference not set to an instance of an object
UnityEditor.ModelImporterClipEditor.FindNextAvailableName (System.String baseName) (at <866e5e4337c74147a9a0249666f72660>:0)

2) NullReferenceException: Object reference not set to an instance of an object
UnityEditor.ModelImporterClipEditor.AnimationClipGUI () (at <866e5e4337c74147a9a0249666f72660>:0)
UnityEditor.ModelImporterClipEditor.OnInspectorGUI () (at <866e5e4337c74147a9a0249666f72660>:0)

  1. Response avatar

    Resolution Note (fix version 2020.2):

    Fixed in 2020.2.0a1

  2. Response avatar

    Resolution Note (fix version 2020.1):

    Fixed in 2020.1.0a26

  3. Response avatar

    Resolution Note (fix version 2019.3):

    Fixed in 2019.3.4f1

Comments (40)

  1. 704c5d887c4f3032daae707b524b0941?d=mm

    nuffd

    Dec 11, 2020 09:40

    Maybe it's a local action oriented command issue. Mine records just 45% success to put figures in it.

  2. 7eedc8b7eb88f5a0a42a26c8af47f7ad?d=mm

    CitrusCorpInc

    Mar 11, 2020 19:32

    Jk, I exported my FBX again and it works now. Ignore my last comment.

  3. 7eedc8b7eb88f5a0a42a26c8af47f7ad?d=mm

    CitrusCorpInc

    Mar 11, 2020 19:20

    I had this exact problem in 2019.3.2f1. I updated to 2019.3.4f1 and it didn't fix anything. I still get those same errors in the console and the inspector is empty.

  4. 9e86dac2616701d38e4e637a78fbdc90?d=mm

    dock

    Mar 09, 2020 15:48

    I no longer get errors in 2019.4, but it also does not update animations!!
    Nothing will make it update animations other than deleting the meta file. I also found this problem in the latest 2018 LTS.

  5. 7dae42a456f99cbd1fc02e40a993a115?d=mm

    jtlthe2

    Mar 06, 2020 14:40

    Upgrading to the most recent release of 2019.3 worked perfectly for me. Thank you so much, y'all! I appreciate you all making and maintaining such a great games toolset.

  6. Fe5aee360c6d4cdda2216fbc2e6c426c?d=mm

    Damon_Yuen

    Mar 04, 2020 09:43

    2019.3.3f1 not working...

  7. Cfa5ea06880479fdca40d74c85767640?d=mm

    trsh

    Mar 02, 2020 18:08

    Ahhh, Fixed in 2019.3.4f1

  8. Cfa5ea06880479fdca40d74c85767640?d=mm

    trsh

    Mar 02, 2020 18:08

    But why it's marked as fixed, if it isn't?

  9. De9496b4fb962b5b9a99111ccd5fffed?d=mm

    VitioPax

    Mar 02, 2020 16:17

    Well, still does't work.

  10. C758f3a7a5d04711668f307d67cf510f?d=mm

    ArkadiuszR

    Mar 01, 2020 22:22

    Still not work o.O

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.