Search Issue Tracker

Fixed in 2017.2

Votes

10

Found in

5.6.0f3

Issue ID

897282

Regression

No

"No PC, Mac & Linux Standalone module loaded" in Facebook Build Settings

Facebook Gameroom

-

To reproduce:

1. Remove Facebook Gameroom build support by going to {Unity Install Folder}\Editor\Data\PlaybackEngines and deleting Facebook folder
2. Open new project
3. Go to Build Settings
4. Select Facebook, it should say "No Facebook module loaded"
5. Click Open Download Page button
6. Install Facebook Games Support
7. Open project created in step 2
8. Go to Build Settings
9. Select Facebook
10. It says No PC, Mac & Linux Standalone module loaded

Expected: PC, Mac & Linux Standalone modules are found when targeting Facebook
Actual: Targeting Facebook Gameroom does not find Standalone modules and says "No PC, Mac & Linux Standalone module loaded

Reproduced in 5.6.0f3, 2017.1.0a6
Could not check for regression in 5.5.2p4 nad 5.51.1f1 for Facebook Gameroom is not supported in those versions.
Could not reproduce in 5.6.0f1 and 5.6.0f2, because Open Download Page opens non - existent page.

Fixed in 2017.2.0b2

Comments (14)

  1. 5e95619413e2e089ee557ae363acf90d?d=mm

    SteveKouts

    Oct 27, 2017 01:56

    Me too im having this problem in 5.6.2f1, Is there any fix yet??

  2. C6238c897f130fba8e4d17c843e15e1d?d=mm

    AlexwellZ

    Sep 17, 2017 04:03

    So, I HAVE to update to 2017.2.0b2 in order to be able to build for Facebook AND PC Windows? How sweet, Unity, how sweet!

  3. 091971bb14983da1b6c6eceb5bb20d89?d=mm

    enzoravo

    Jul 23, 2017 00:24

    i found this issue in unity3d 2017.1 too, i was able to build for pc deleting the facebook folder from {Unity Install Folder}\Editor\Data\PlaybackEngines

    when i have deleted the facebook folder i was able to build again for pc, mac and linux.

    this is an unofficial solution, maybe just worked only at my end, but hope this will help someone.

  4. Ee259c7d73c69506180279d770b2a39b?d=mm

    ofnature

    Jul 15, 2017 22:44

    This is definitely not fixed.

  5. Fa92699efd2c2e555e582c09d84aa3b3?d=mm

    Cliwo

    Jun 27, 2017 05:09

    Hi I found the way to solve this problem. (I'm using 5.6.2f1)
    accidentally I installed 5.6.0f3. (to check whether we can't build on gameroom platform for all version)
    installed it in another directory (not Unity folder but some other folder, in my case that was Unity5.6.0 that I made manually)

    Open the Unity 5.6.0f3 and build test project (I made a cube on 0,0,0 position. Save scene
    and build it on facebook gameroom)
    The build was successful
    After that I re-open the Unity5.6.2f1 (I installed 5.6.0f3 to other folder so I could open it)
    and I found that there is no module bug on 5.6.2f1

    this is not a official solution and this may work only in my case
    but if you are desperate, you can try this.

  6. Fa92699efd2c2e555e582c09d84aa3b3?d=mm

    Cliwo

    Jun 26, 2017 07:33

    I'm having same problem on 5.6.2f1

  7. 876fe9e1ae57fb8404c11f35080d5975?d=mm

    silvershunt

    Jun 15, 2017 11:24

    Hi Unity,
    This issue is still not resolved. I have this exact same problem in Unity 5.6.1f1 two days ago.
    And up to now, no one can seem to find the solution on why this is happening.

    I just upgraded to Unity 5.6.1f1 and then use it for a few days. But then when I install the facebook module, the PC windows module cannot be detected by Unity anymore. So now I cannot build my application in Windows platform.

    Please fix this Unity, please....

  8. 73acca81d1c19353d45c4667f9f3d7c0?d=mm

    Dreaded-Kane

    Jun 09, 2017 06:44

    Me too, Unity 5.6.1f1. How do we fix it?

  9. 6a96aef977345c3f19bf81c33dc59900?d=mm

    alto971

    May 12, 2017 17:04

    same for me..once iv'e chosen Facebook Build, i can't build anymore for windows !! Urgent ...fix it !!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.