Search Issue Tracker

Fixed in 5.3.0

Votes

2

Found in

4.3.3f1

Issue ID

587583

Regression

No

MonoDevelop doesn't start - solved by overwriting glibsharpglue-2.dll

CodeEditors

-

The problem is not with the Unity editor itself, but rather with the bundled Monodevelop with the initial install. I'm participating in a game jam and picked up Unity to assist in the game development. After initial setup I tried opening a script from the example 2D project. Everytime I would try to open a script the Monodevelop starting logo would appear, but then it would immeadiately crash. There was no error or pop up to accompany the crash. Eventually I found the solution online. There seems to be a problem with the glibsharpglue-2.dll in the bin folder of Monodevelop. The solution I found was to download the file from the previous verison of Unity/Monodevelop and replace the existing file with the previous version.

Comments (3)

  1. 6d76295a33901344aa51ca0c9934e552?d=mm

    Adam_Turner

    Apr 10, 2015 19:35

    But how???? This error is really bugging me now because it opened the first few times but then stopped working

  2. D56252c243b8993664cdc43f96ed22da?d=mm

    Lichter

    Aug 15, 2014 19:50

    I just updated to 4.5.3f3 and discovered exactly the same behavior. I resolved the problem simply by deleting that file. Strange.

  3. B333bd07ad5e9a2d70cda8d9311287e9?d=mm

    davidk99

    Jun 13, 2014 18:35

    Where can I donwload this file?I don't have it from older versions

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.