Search Issue Tracker

Fixed in 2018.3.X

Fixed in 2019.1.X



Found in





Issue ID




MissingReferenceException and broken GUI after enter/exit Play mode with Script Execution Order tab open



How to reproduce:
1. Open the attached "" project or create a new one
2. In the Menu bar, select "Edit/ Project Settings..."
3. In the Project Settings window, make sure that the "Script Execution Order" tab is selected
4. Enter the Play mode
5. Exit the Play mode
6. Observe the Console window

Expected result: The Console does not contain any errors and Project Settings window is not broken.
Actual result: There are multiple errors in the Console and GUI of the Script Execution Order tab is broken (it is empty, hovering the mouse over it produces even more errors).

Reproducible with - 2018.3.0a4, 2018.3.3f1, 2019.1.0a15, 2019.2.0a2
Not reproducible with - 2017.4.19f1, 2018.3.0a3

Note: The regression was introduced (in 2018.3.0a4) along with the new Project Settings window. (Prior to that, "Script Execution Order" would appear in the Inspector window.)

Errors thrown:
- "MissingReferenceException: The object of type 'MonoScript' has been destroyed but you are still trying to access it. <...>"
- "ArgumentException: GUILayout: Mismatched LayoutGroup.repaint <...>"
- "GUI Error: You are pushing more GUIClips than you are popping. Make sure they are balanced. <...>"
- "Scope was not disposed! You should use the 'using' keyword or manually call Dispose. <...>"

  1. Resolution Note (fix version 2018.3):

    Fixed in 2019.2.0a5
    Backported to 2018.3.7f1, 2019.1.0b3

Comments (16)

  1. taynaTinoco

    Jul 01, 2019 14:18

    same happened when a try to build for android in Unity 2019.1.5f1

  2. lpt0

    Jun 13, 2019 21:35

    Same issue in Unity 2019.2.0b5
    Installed after a few minutes, switched to Android and tried to open the Player Settings... nothing was displayed in the window and the errors were shown in the console...

  3. ziemlich3D

    Jun 07, 2019 16:17

    I'm also facing this problem in 2019.1.5f1. Seems still not fixed...

  4. DrunkenMastah

    May 21, 2019 22:03

    Yep... Still an issue in Unity 2019.1.3f1

  5. firstuser

    May 17, 2019 21:18

    Still an issue in Unity 2019.1.3f1

  6. Aseemy

    Apr 10, 2019 17:37

    Same issue in Unity 2018.3.12f1
    So i guess its not fixed.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.