Search Issue Tracker

Fixed in 2017.3.0f3



Found in


Issue ID




'Missing Behavior' component can not be seen or removed from Game Objects it was assigned to

Inspector Framework


After a script is deleted, it is impossible to see the 'Missing Behavior' component to remove it from game objects it was assigned to.

To reproduce:

1. Download attached project "" and open in Unity
2. Open "BehaviourMissing" scene
3. Enter to Play mode

To reproduce from scratch:
1. Create a C# Script called "TestingScript.cs"
2. Create a "TestingGameObject" GameObject in the Scene
3. Assign TestingScript.cs to TestingGameObject
4. Run. Ensure no warnings
5. Delete TestingScript.cs. Do not delete TestingGameObject
6. Look at TestingGameObject. It says it is missing the script (normal)
7. Run.
8. Warning about missing behavior appears (NORMAL & EXPECTED)
9. Stop the Scene
10. Look at the TestingGameObject

Expected Result: GameObject should have an empty script entry with 'Missing Behaviour' so you can add a new one or remove it.
Actual Result: The missing behavior can not be seen. No way to delete or reassign it. You need to delete the game object to get rid of the warnings.

Reproduced on Unity 2017.1.0b6, 2017.1.0b8 and 2017.2.0a2
Not reproduced on Unity 2017.1.0b5
Regression on Unity 2017.1.0b6

Comments (5)

  1. phillipesq

    May 11, 2024 23:49

    I have this problem in Unity 2022.3.14f1:

    "The referenced script (Unknown) on this Behavior is missing"

    Which object? Which script?

    Does anyone know how I can modify this system message so that it writes the name of the object and script as soon as the absence is detected, as soon after all the files are deleted or recreated and I simply don't know what it would be!

  2. drHogan

    Jul 15, 2019 10:05

    Hi, 2018.4 and I have the same issue

  3. robinjansen51

    Jun 18, 2019 19:12

    I'm using 2019.2.0b4 and have the same issue.

  4. snarlynarwhal

    Feb 20, 2019 04:04

    I use 2018.3.6 and also have this issue.

  5. dougdodd

    Feb 15, 2018 01:28

    I am using Unity 2017.3.0f3 and the issue is still here. I inherited this project from someone else and I have 999+ of these warnings. Tried reimporting all, tried making custom package of everything and importing this into new project. Still have 999+ of these warnings.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.