Search Issue Tracker

Fix In Review for 2020.2

Fix In Review for 2019.4, 2021.1

Votes

2

Found in

2018.3.0f1

2018.4.0f1

2018.4.24f1

2019.4.0f1

2020.1

2020.2

2021.1

2021.2

Issue ID

1255995

Regression

No

[Metal][Mac] Artifacts appear in Prefab mode if Metal Editor support is enabled

Metal

-

Steps To Reproduce:

1. Create a new project
2. Hierarchy > 3D> Cube
3. Drag the cube to Project window to make a Prefab
4. Double click the Prefab to view it in Prefab mode > drag Game object
5. Ensure that the skybox is turned off in Scene Effects dropdown option

Observed Result:
Weird artifacts appear in the Prefab Mode

Expected Result

Prefab mode opens up without any issues

Reproducible On: 2018.4.24f1, 2018.4.20f1, 2018.4.0f1, 2018.3.0f2, 2021.1.0a4, 2021.2.0a1

Workaround: Disable Metal Editor Support in Player Settings

Environment:

Occurs only on macOS Catalina, only with Intel UHD/HD Graphics 630 cards.

  1. Response avatar

    Resolution Note (fix version 2020.2):

    A solution is in the next release. In the meantime, the issue is specific to MacOS Catalina with some Intel graphics cards, and can be worked around by upgrading to MacOS Big Sur or by going to Unity->Preferences...->Colors to set the alpha value of the "Background" color and "Background for Prefabs" color to 1.

Comments (1)

  1. 33d072c3b72b212dd816ed1ee580e2c6?d=mm

    KokodokoGames

    Sep 24, 2020 10:18

    I experience the same pixelated grid. In my case it happens when I import a .unitypackage from an older version of Unity. I was able to fix it by creating a new scene and copy>pasting all gameobjects manually from the old scene to the new scene. I also had to throw away an auto-generated lighting object that appeared in the projects pane after importing the package.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.