Search Issue Tracker

Fixed in 2019.3

Votes

0

Found in

2019.3.0a6

Issue ID

1173662

Regression

Yes

[Linux] Cannot run editor as Glibc 3.4.20-21 is required but unavailable in CentOS 7

Linux

-

[Linux] Cannot run editor as Glibc 3.4.20-21 is required but unavailable in CentOS 7

As of 2019.3.0a11, Unity (Linux) requires Glibc 3.4.20/3.4.21. As these versions of Glibc are currently unavailable in CentOS 7, the editor cannot be run, reporting the following errors:

~/Unity-2019.3.0a6/Editor/Unity: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ~/Unity-2019.3.0a6/Editor/Unity)
~/Unity-2019.3.0a6/Editor/Unity: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ~/Unity-2019.3.0a6/Editor/Unity)

Steps to reproduce:
1) On a machine running CentOS 7, install Unity 2019.3.0a6
2) Open the Unity installation
3) Observe the noted Glibc errors reported to console and that the editor will fail to run

  1. Response avatar

    Resolution Note (fix version 2019.3):

    Cannot reproduce in 2019.3.0a12

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.