Search Issue Tracker

Fixed in 5.5.1



Found in


Issue ID




[iOS] Unity splash screen doesn't show up on iOS builds



Steps to reproduce:
1) Create a new project.
2) Build for iOS.
3) Run on a device.

The game loads directly to the main scene; the splash screen animation is skipped.

Reproduced on:
5.5.0f3 (38b4efef76f0), 5.6.0b1

Did not reproduce:
5.5.0f3 (1d1a0b50d15c), 5.4.3p3

Comments (11)

  1. raydekk

    Jun 11, 2017 19:50

    It's still happening for 5.6.1p3

  2. kimmie52

    Apr 16, 2017 01:38

    This issue is not resolved even with new Unity releases i.e. 5.5.2f1, 5.5.3f1, and latest release 5.6.0f3. Absolutely annoying to have a bug not fix for over four years. Yes, how we reopen this case and get a fix ASAP? My project is on-hold because I can't find a proper solution.

  3. yruizw

    Feb 28, 2017 18:52

    I was building my project with Unity 5.5.0p4, for android in this case the issue of the black splash screen is solved, but on IOS I have the issue, so just following this post I decided to update to 5.5.1.p4 and here the issue now is on Android.
    Do you know which is the right release in which this issue is solved for Android and IOS?
    Thanks in advance

  4. abdulahadm258

    Feb 14, 2017 07:06


    I was facing the same issue with Unity 5.5.0 and tried Unity 5.5.1f1 which is the latest version. But still, Splash screen is not showing up. So this issue is not fixed yet.

  5. infosekr

    Feb 05, 2017 05:43

    I am seeing a partially black screen (a black square and white boxes on either side) on iOS instead of the usual black screen while unity starts and loads my first scene. I have the Unity splash turned off and show my own splash on the first scene (Unity Pro). This started happening in Unity 5.5.0f3 but still happens in Unity 5.5.1p2. This does not happen for Android. I assumed that what I'm seeing is this problem, but possibly this is a new issue. Can anyone confirm?

  6. Vaidas_Budrys

    Jan 25, 2017 06:27

    The fix for this bug will be released with Unity 5.5.1p1.

  7. Shaolin-Dave

    Jan 24, 2017 16:16

    Today 5.5.1 was released. This is in the release notes under "known issues":

    iOS: Unity splash screen doesn't show up on iOS builds (856772). This will be fixed in a future patch release.

  8. geoffa

    Jan 17, 2017 22:17

    Am curious when this issue will be reopened and resolved. I don't see another recent ticket about this. Thanks!

  9. Siginami1

    Dec 17, 2016 20:50

    This bug is still present in 5.5.0f3

  10. Shaolin-Dave

    Dec 17, 2016 05:05

    This is marked "Status: Fixed in Unity 5.5.0"

    I just checked, as of 5.5.0p1, it's still not fixed.

    How do we reopen this?

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.