Search Issue Tracker

Fixed in 2018.2.X

Fixed in 2017.3.X, 2017.4.X, 2018.1.X



Found in



Issue ID




[iOS] Rigidbody interpolation causes objects to jitter



Steps to reproduce:
1. Download the user's attached project
2. Build to iOS
3. Observe the cube travelling in the screen

Expected: cube travels from left to right smoothly
Actual: cube jumps multiple times

Did not reproduce on: 2017.1.2p3, 2017.2.0a3
Reproduced on: 2017.2.0a4, 2017.2.0p3, 2017.3.0b11 (OpelGLES2 & Metal)

Regression introduced in: 2017.2.0a4

Reproduced with: iPhone 6S, iOS 11.0 (15A372)

Also reproduced on android:
Htc HTC 10*, OS:7.0, CPU:arm64-v8a, GPU:Adreno (TM) 530, Build:htc/pmeuhl_00401/htc_pmeuhl:7.0/NRD90M/857212.41:user/release-keys

Samsung SM G930F*, OS:7.0, CPU:arm64-v8a, GPU:Mali-T880, Build:samsung/heroltexx/herolte:7.0/NRD90M/G930FXXS1DQHF:user/release-keys

Xiaomi MI NOTE Pro*, OS:7.0, CPU:arm64-v8a, GPU:Adreno (TM) 430, Build:Xiaomi/leo/leo:7.0/NRD90M/7.11.2:user/release-keys (edited)

Comments (41)

  1. smirk

    May 01, 2018 13:43

    I haven't tried 2017.4.2f2. Only tested 2018.2 Beta and it is fixed.

  2. user099

    Apr 30, 2018 11:46

    Fixed in 2018.2 Beta or 2017.4.2f2 ?

  3. smirk

    Apr 29, 2018 17:30

    I confirm that fix. Not getting any jittery movement of rigid bodies on IOS anymore. Thanks.

  4. bluescrn

    Apr 11, 2018 23:13

    Another forum thread, as I've just run into this issue too:

    I created a little test project that really shows the judder by intentionally causing the framerate to fluctuate (turning expensive particle effects on/off), as that's when the problem can go from occasional small judders to something more dramatic.

    Doesn't happen in the editor (only seen on iOS/Android so far), most noticable when the framerate is varying, doesn't affect 2D physics.

  5. MorenoBralts

    Apr 11, 2018 07:12

    FYI ; I'm also able to reproduce this issue in LTS 2017.4.1

  6. MorenoBralts

    Apr 10, 2018 08:22

    Anyone tried in LTS 2017.4.1 ?

  7. smirk

    Apr 05, 2018 08:32

    We need that reviewed please.

  8. kivan_mih

    Mar 18, 2018 07:39

    Bastard bug and NOT fixed YET! My game is killed by it! Damn unity :(

  9. gwiasdeczka2

    Mar 15, 2018 22:04

    Is there any progress on the review? Seems to be a blocker for me.

  10. MoribitoMT

    Mar 15, 2018 13:44

    Still having this issue with 2017.3.1.p4

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.