Search Issue Tracker

Active

Under Consideration for 2021.3.X, 2022.1.X

Fixed in 2022.2.0b14, 2023.1.0a15

Votes

2

Found in

2021.3.6f1

2022.1.7f1

2022.2.0a17

2023.1.0a1

Issue ID

UUM-8012

Regression

Yes

[HDRP] Error thrown on clicking the "Embed Configuration Editable Package" button in the HDRP Wizard window

--

-

Steps to reproduce:
1. Create a project with HDRP Template
2. Window > Rendering > HDRP Wizard
3. Embed Configuration Editable Package > Click

Actual Result: Error is thrown on clicking the Embed Configuration Editable Package button
Expected Result: No error is thrown in the console

Reproducible with: 12.0.0, 12.1.7, 13.1.8, 14.0.3, 15.0.0 (2021.2.0b15, 2021.3.6f1, 2022.1.7f1, 2022.2.0a17, 2023.1.0a3)
Not reproducible with: 10.9.0, 11.0.0 (2020.3.36f1, 2021.2.0a2)

Reproduced on: Windows 11

Error logged: Failed to install the config package Failed to embed package [com.unity.render-pipelines.high-definition-config]: The package must be a direct dependency of the project. UnityEditor.EditorApplication:Internal_CallDelayFunctions ()

  1. Resolution Note (fix version 2023.1.0a15):

    Fixed in 2023.1.0a15

  2. Resolution Note (fix version 2022.2.0b14):

    Fixed in 2022.2.0b14

Comments (2)

  1. nathan122

    Nov 16, 2022 20:45

    Reproduced on Unity 2021.3.11f1

  2. apexape

    Jul 14, 2022 19:20

    Is reproduceable on Window 10 as well.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.