Search Issue Tracker


Fixed in 3.3.0



Found in [Package]


Issue ID




Getting console error when postprocessing package is installed: ArgumentException: Type provided must be an Enum.

Package: PostProcessing


How to reproduce:

# Create new Unity Project
# In Context menu select Window > Package Manager
# In package manager windows click on plus icon
# In dropdown select 'install package from git URL...'
# Enter this link '' and press Install
# Wait for install to complete and check console

System.ArgumentException: Type provided must be an Enum.
Parameter name: enumType
at System.RuntimeType.GetEnumValues () [0x00012] in <e1eafe244ab8433bb57e5e98843c8df1>:0
at System.Enum.GetValues (System.Type enumType) [0x00014] in <e1eafe244ab8433bb57e5e98843c8df1>:0
at UnityEditor.Rendering.PostProcessing.DefineSetter..cctor () [0x00000] in /home/bokken/My project (5)/Library/PackageCache/com.unity.postprocessing@b336715bc7/PostProcessing/Editor/Tools/DefineSetter.cs:17
UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes (System.Type[]) (at /home/bokken/buildslave/unity/build/Editor/Mono/EditorAssemblies.cs:123)

Expected results: No errors in console.
Actual results: Errors are thrown in the Console window

- Tested on Win11, Ubuntu 18.
- Not reproducible with version 3.2.2.
- Also tried same package install from disk and got the same error

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.