Search Issue Tracker

Fixed in 2019.2

Votes

38

Found in

2019.2.0a5

2019.2.0a10

2019.3.0a1

Issue ID

1142442

Regression

Yes

[Facebook] Editor throw errors related to SDK after Facebook support installation

Facebook Gameroom

-

How to reproduce:
1. Create an empty project (notice that Facebook support should be installed later)
2. Try to build it on standalone (Everything works fine)
3. Go to Build Settings and download Facebook build support
4. Install the module and re-open the project

Expected results: No errors in the console
Actual results: Editor spawns 4 errors related to Facebook SDK can be seen in the console

Reproducible with: 2019.2.0a5, 2019.2.0b2, 2019.3.0a2
Not reproducible with: 2017.4.27f1, 2018.4.0f1, 2019.1.3f1, 2019.2.0a4

  1. Response avatar

    Resolution Note (fix version 2019.2):

    Fixed in 2019.2.5f1. Facebook Gameroom is deprecated, and will be removed in upcoming 2019.3 and 2020.1 releases

Comments (7)

  1. 4c3836f8aac83028044030c1402d75ef?d=mm

    mattparishdev

    Sep 07, 2019 12:00

    Could we please get a release date for 2019.2.5f1 as it is not yet available in Unity Hub? Thanks

  2. Bbd372e2ffa47a7575308b27e195f119?d=mm

    DRY1994

    Aug 27, 2019 02:50

    Unity 2019.2.2f1 is showing these errors as well today (8-2-2019).

    Extension C:/Program Files/Unity/Hub/Editor/2019.2.2f1/Editor/Data/PlaybackEngines/Facebook/SDK/7.9.4/Facebook.Unity.Arcade.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

    Extension C:/Program Files/Unity/Hub/Editor/2019.2.2f1/Editor/Data/PlaybackEngines/Facebook/SDK/7.9.4/Facebook.Unity.Settings.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

    Extension C:/Program Files/Unity/Hub/Editor/2019.2.2f1/Editor/Data/PlaybackEngines/Facebook/SDK/7.9.4/Facebook.Unity.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

    Extension C:/Program Files/Unity/Hub/Editor/2019.2.2f1/Editor/Data/PlaybackEngines/Facebook/SDK/7.9.4/FacebookNamedPipeClient.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

    They aren't completely system breaking as I can click clear and be on my merry way. Although It's still unsettling and could get really annoying if I wanted to create a Facebook game.

  3. 87e00faec887bd41d70968910420c189?d=mm

    debraycodes

    Aug 25, 2019 17:28

    Unfortunately having the same error... May temporarily install a Unity version w/o FB support...

  4. F95c4063affb9985efbf307634d9c111?d=mm

    Omekka

    Aug 25, 2019 15:20

    Its kind of a little annoying as well as not compiling at all ..... so Unity do your magic , can you ?

  5. 7dc93eaaf3522c8365f7f296d0ee6722?d=mm

    Dragonarkon

    Aug 20, 2019 05:44

    Same Errors Present in Unity 2019.2.1f1

    Extension C:/Program Files/Unity/Hub/Editor/2019.2.1f1/Editor/Data/PlaybackEngines/Facebook/SDK/7.9.4/Facebook.Unity.Arcade.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

    Extension C:/Program Files/Unity/Hub/Editor/2019.2.1f1/Editor/Data/PlaybackEngines/Facebook/SDK/7.9.4/Facebook.Unity.Settings.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

    Extension C:/Program Files/Unity/Hub/Editor/2019.2.1f1/Editor/Data/PlaybackEngines/Facebook/SDK/7.9.4/Facebook.Unity.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

    Extension C:/Program Files/Unity/Hub/Editor/2019.2.1f1/Editor/Data/PlaybackEngines/Facebook/SDK/7.9.4/FacebookNamedPipeClient.dll was not registered, that means it relies on default UnityExtensions settings, please register extension and apply necessary settings for it in the callback.

  6. 562ae51292848eaa3792f2f57a75c907?d=mm

    Chris-NeonTree

    Aug 16, 2019 07:55

    Project upgraded from 2019.1.7f1 to 2019.2.0f1. Unity crashes just after opening the project + Editor spawns 4 errors related to Facebook SDK.

  7. F7e171b118d6c6cec5d33c2cf9f7991c?d=mm

    StarFluke

    Aug 14, 2019 07:28

    Happening in Version 2019.2.0f1 (20c1667945cf)
    Fri, 19 Jul 2019 07:25:00 GMT
    Branch: 2019.2/staging

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.