Search Issue Tracker

Fixed in 2021.2.X

Fixed in 2021.1.X

Fix In Review for 2020.3.X

Votes

0

Found in

2019.4.24f1

2020.2.2f1

2021.1

2021.2

Issue ID

1310050

Regression

Yes

[DSPGraph] Audio stops after ~60 seconds when playing in the Editor mode

Audio

-

Reproduction steps:
1. Open the user's attached project and Samples/DSPGraph Audio Framework/0.1.0-preview.16/Simple DSPGraph examples/PlayClip/PlayClip scene
2. In the Hierarchy window, select PlayClip GameObject
3. In the Inspector, right-click on the Play Clip (Script) component and select Play Sound
4. Listen to the audio for up to ~60 seconds

Expected result: Audio is played
Actual result: Audio stops after ~60 seconds from the last time the Editor mode was entered

Reproducible with: 0.1.0-preview.13 - 0.1.0-preview.17 (2020.2.2f1, 2020.2.3f1, 2021.1.0b5, 2021.2.0a4)
Not reproducible with: 0.1.0-preview.13 (2019.4.20f1, 2020.2.1f1)
Could not test with: 2018.4.31f1 (could not downgrade)

Notes:
1. The 60 seconds starts ticking when Editor mode is started, not when Audio is started playing
2. When Play Sound is pressed after the Audio stops, the Audio will not be played
3. The Audio will be played for 60 seconds again, after entering the Play mode

  1. Response avatar

    Resolution Note (fix version 2021.2):

    Fixed in 2021.2.0a12

  2. Response avatar

    Resolution Note (fix version 2021.1):

    Fixed in 2021.1.3f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.