Search Issue Tracker

Fixed in 5.2.0

Votes

18

Found in

5.0.0f2

Issue ID

674542

Regression

Yes

[Deferred] Trees created using Tree Creator generate white spots with deferred rendering path

Terrain

-

Steps to reproduce:

1. Open the attached project
2. Open the 'GM Island' scene
3. Notice the white spots on the trees
4. Switch to any other rendering path
5. Notice the white spots are no longer visible

Comments (16)

  1. B70be5d23c0a4255ee079feb1a433c9e?d=mm

    FlorianBernard

    May 25, 2017 21:16

    This is not fixed in 5.6

  2. 985f1e229cfebe6610ac8c425fdd5d99?d=mm

    HardyM

    Aug 02, 2015 21:57

    I believe that's some kind of problem with z-buffer and shadows in deferred, and it extends to the legacy one. You can switch your path rendering to forward, and if it did not solve, toggle in the tree prefab the receive shadows option.
    For me worked using deferred, when I disabled the receive shadows in each one, but when I turn on Sun Shafts, Motion Blur or Depth of Field, it gives the same error.

  3. B11df18267ef05329954cfe0f70d12f9?d=mm

    heskethgames

    Jun 29, 2015 21:11

    Still broken for me. Any solution yet? I am on 5.1.1f1

  4. A798be4309dc91891c701d58dc9d6e8c?d=mm

    Nieles

    Jun 02, 2015 20:25

    Still not fixed in 5.0.2!

  5. 8ac2d55ca62893547c90a418dee57e28?d=mm

    amarchal

    May 26, 2015 05:09

    Not fixed. I have tried all the betas up to 5.1.0f1 and I still see this issue. It says it was fixed in a future release, what release is being referred to? In my specific case the trees are being brought over from a unity 4.6 scene and they have gross white fringe coming from the optimizedLeafMaterial shadow component going all kinds of wrong under deferred shading.
    switching to to SM model 2 is not the real fix correct?

  6. 65bb36fe7085c04384b33ec902fd764a?d=mm

    Stargazer1974

    May 19, 2015 18:47

    For me, this is not fixed!

  7. Fbac4884141d5db56d98c8e9ba45eae5?d=mm

    Gregu

    May 05, 2015 13:17

    Bumping this.

    Picture:
    http://i.imgur.com/6W3fM9F.jpg

  8. 40e78e0c414907f900af9a1da59dfd5a?d=mm

    Remiel

    May 02, 2015 18:00

    "The White outlines on tree creator trees in forward rendering can be fixed by turning off Anti-Aliasing ."
    I have it turned off and the issue persists as shown in thread http://forum.unity3d.com/threads/unity-5-something-weird-with-trees-alpha-textures.307372
    This is an issue with speed tree shaders.

    "I temporarily fixed it guys
    try to change your graphics emulation to shader 2 or 3"
    Turning the emulation to shader model 2 makes the issue disappear in editor, however, it still remains for shader model 3.

    This is a big issue as it makes me choose between using trees or using deferred. Naturally, it makes me unable to use deferred which is a huge problem in it's own right. Please fix this as soon as possible.

  9. E96df13aff5138fedf2d90faf67abd33?d=mm

    Zaxs_Reaper

    May 01, 2015 15:01

    I temporarily fixed it guys
    try to change your graphics emulation to shader 2 or 3

  10. Bb7862d87b3663de1098972856331a83?d=mm

    Kunani

    Apr 18, 2015 06:08

    Problem still exists in 5.0.1p1 patch release from April 15th. Easy noticeable if using a spot light.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.