Search Issue Tracker

Fixed in 2019.2

Votes

0

Found in

2018.3.0a1

2018.3.3f1

2019.1.0a1

2019.2.0a7

Issue ID

1121794

Regression

Yes

SkinnedMeshRender with blend shapes gives "Thread group size must be above zero" error when GPU skinning is enabled

Graphics - General

-

Reproduction steps:
1. Open the attached project named "Case_1121794"
2. Try to move the "ExampleScene" object in the Sample scene
3. Observe the console

Expected result: No error messages are thrown
Actual result: Error messages are thrown

Reproducible with: 2018.3.9f1, 2019.1.0a8, 2019.2.0a7, 2019.2.0a8
Not reproducible with: 2019.1.0a9, 2019.1.0b7, 2019.2.0a6
Could not test with: 2017.4

Notes:
Could not test with 2017.4 due to overhauled prefabs
With 2019.2.0a7 and above no more pink textures are shown, however, the error messages remain
The bug is caused by one of the 'o' objects located in the prefab(Snapshot_1121794_V1)

Comments (2)

  1. Eb942822bbe5420648f248b7a7e5de79?d=mm

    AndyKorth

    Oct 10, 2019 21:15

    I would also love to see this issue backported. We're locked into 2019.1 at the moment and we're running into it, but only when the blendshapes are enabled:

    https://i.imgur.com/aSAYyM6.png

  2. 104e7a27c612efac575ba55db7ae50cf?d=mm

    daisySa

    May 12, 2019 23:35

    This issue doesn't occur in 2017.4; it only began when we upgraded to 2018.4. It's a massive issue for us as disabling GPU skinning drops our frame rate from 60 fps to 35 fps in some scenes.

    Does anyone know roughly how long it will take for this to be back-ported to 2018.4?

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.