Search Issue Tracker

Fixed in 2018.3.X

Fixed in 2018.2.X

Votes

3

Found in

Issue ID

1059497

Regression

Yes

Console Warnings For Duplicate GUIDs For Plugins Shipped In Packages

XR SDK

-

End users and Unity employees have reported the presence of console messages that warn of duplicate GUIDs. This is caused by the way that packages are duplicated in the cache.

GUID [dbca4b5d18c5b4a59ad11c981347242d] for asset 'Packages/com.unity.xr.arkit/Runtime/iOS/UnityARKit.a' conflicts with:
'/Users/matt/Library/Unity/cache/packages/packages.unity.com/com.unity.xr.arkit@1.0.0-preview.12/Runtime/iOS/UnityARKit.a' (current owner)
We can't assign a new GUID because the asset is in an immutable folder. The asset will be ignored.

Comments (28)

  1. 1acc5934e63b642667db76a415f23af0?d=mm

    giantkilleroverunity3d

    Apr 09, 2021 02:56

    I have this issue in 2020.1.10f1 with Unity post processing which Amplify Shader Editor is reliant on.

  2. 005e48a595d2620e2e64de4dc1e9d5be?d=mm

    sang

    Mar 30, 2021 08:27

    This still presents in 2019.4.8

  3. C35b9264646fd1b72f6ccfca2622c409?d=mm

    AlanMattano

    Jul 19, 2020 15:19

    I've got this warning:
    GUID [dfc600c537737824fb131f9a395438fe] for asset 'Assets/StreamingAssets/...' conflicts with:
    'Assets/StreamingAssets/...' (current owner)
    Assigning a new guid.

    I do not know how to fix it

  4. 1c6cbea449b28117c47caceebee9aa8c?d=mm

    CodexofRome

    Jul 13, 2020 18:13

    Not fixed in 2019.4 LTS

  5. Fbd0b8bdbc59551a57f01b90b1443629?d=mm

    lockme-illuminati

    Jun 04, 2020 01:11

    i imported the free sun template terrain and got this issue , because i had recently installed post processing recently trying to mess with ecs .

    the sun template had its own post processing folder , i went to package manager and removed post processing and restarted unity and it cleared the error .

  6. 78d79399e20c412fa52faa8100800a1a?d=mm

    unbreakable3D

    May 29, 2020 20:32

    Problem exists for me in 2019.3.11f1. Conflict occurring with DoozyUI and Asset Graph packages - both use LineDraw shader.

  7. 0725a1ddfa524881b0fc3ee988b9030c?d=mm

    ahmetala

    May 29, 2020 12:32

    Installing Unity Ads To ensure the latest version of Unity Ads, download it through the Asset store, or through the Unity Package Manager in the Editor.

    Important: You must choose either the Asset or the package. Installing both may lead to build errors.
    https://unityads.unity3d.com/help/unity/integration-guide-unity#basic-implementation

  8. B787702db378947075fa8b4104c9d391?d=mm

    sebi3110

    May 18, 2020 04:16

    2019.3.11f1

    GUID [c0ae98308ab0475a9583e1ea6e82ec65] for asset 'Packages/com.google.firebase.messaging/Plugins/Android/AndroidManifest.xml' conflicts with:
    'Assets/Plugins/Android/AndroidManifest.xml' (current owner)
    We can't assign a new GUID because the asset is in an immutable folder. The asset will be ignored.

  9. C5874d8179ac973a248585c4c81c1159?d=mm

    Muntasir

    May 05, 2020 22:10

    using 2019.3.12f1 and getting similar error. Its not fix yet??

    `GUID [c0ae98308ab0475a9583e1ea6e82ec65] for asset 'Packages/com.google.firebase.messaging/Plugins/Android/AndroidManifest.xml' conflicts with:
    'Assets/Plugins/Android/AndroidManifest.xml' (current owner)
    We can't assign a new GUID because the asset is in an immutable folder. The asset will be ignored.`

  10. C5874d8179ac973a248585c4c81c1159?d=mm

    Muntasir

    May 05, 2020 22:07

    Getting error in 2020 :/ Anybody found any fix yet?

    Error:
    `We can't assign a new GUID because the asset is in an immutable folder. The asset will be ignored.`

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.