Search Issue Tracker

Fixed in 5.2.1

Votes

0

Found in

5.2.0f3

Issue ID

725106

Regression

Yes

Caret does not appear in the input field and cannot select the text

uGUI

-

Steps to reproduce :

- create a new input field and press play
- click inside the field and notice the caret is missing
- type something, try to select it and notice it doesn't work

*Note :
Seems to work fine in 5.1.

Comments (15)

  1. 268e488556c0e9e604ef13d23f63ce62?d=mm

    ModLunar

    Sep 06, 2019 00:45

    EDIT: (I wish I could edit my original comment) -- It turns out, I was using a Mask that was hiding it, because the caret is so far to the left when there are no characters written out in the InputField. Hmmm hope this is not to hectic to adjust then!

  2. 268e488556c0e9e604ef13d23f63ce62?d=mm

    ModLunar

    Sep 06, 2019 00:33

    Caret still doesn't appear when InputField's text is empty, in Unity 2019.2.0f1, despite being selected. Not completely fixed.

    When there *is* text in the InputField, however, it does properly show the caret.

  3. C65bab019c2dcb16cf8ef6d7823a5dfa?d=mm

    600

    Jul 17, 2019 10:04

    Posting for myself for future reference and may help others,
    in Unity 2017.4.22f1 can write, but missing caret. Solved by deleting other added elements in the InputField group
    https://i.imgur.com/JbWE48e.png
    Caret goes invisible when other objects added because the caret is spawned as first sibling in hierarchy and blocked by other elements

  4. E515e5a4dfdcf759509ab3eb8cb236af?d=mm

    Arvizio_JD

    Feb 01, 2019 18:00

    Issue still present in 2018.1.9f2-MLTP10

  5. 95dcf58f7f0a1dc6ec75c81ace184860?d=mm

    Wolokos

    Aug 26, 2018 17:51

    Is it possible that some people with this problem have the wrong text size for their input field? I noticed that even though the text didn't appear on the screen, the text field was still taking input. So I selected "best fit" for my text size and suddenly my caret and text appeared again. I felt like an idiot.

    Not sure what's going on for the people whose input fields aren't taking input, though.

  6. A1b33a6c3e4012af4fccdbc97395c695?d=mm

    Stolorg

    Mar 22, 2018 15:11

    version 2017.3.0f3. Windows 10 desktop.

    No caret, no text, no input in input field. Field can be clicked, highlighted, etc... but takes no input.

  7. 0796ad749b47dd2b48c8694e7cd322d1?d=mm

    SSUAR

    Mar 16, 2018 11:39

    I have this issue in latest version of Unity. I have a panel with 8 input fields the 4 on the left have no caret but the 4 on the right have the caret. They all have the same caret settings in the inspector. Please fix this.

  8. Fb92c95d416dc046702f32d5e27d890c?d=mm

    andrew_o1995

    Feb 20, 2018 03:21

    AUSTINBORDEN, same here. I'm using Unity 2017.0.0f3 to develop a VR app and it is really annoying not having the caret.

    Please fix! Thanks :)

  9. F04ec5f91aa701ef6be34d59a13d3c7c?d=mm

    austinborden

    Jan 11, 2018 19:52

    This still happens in 2017.3.0f3. Caret is there but not visible like previous poster said.

  10. 3d3641114dcc05dc169820ee3bdcf56a?d=mm

    adehm

    Sep 14, 2017 17:05

    version 2017.1.0f3

    Caret is there as an object but invisible.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.