Search Issue Tracker

Fixed in 5.2.1

Votes

0

Found in

5.2.0f3

Issue ID

725106

Regression

Yes

Caret does not appear in the input field and cannot select the text

uGUI

-

Steps to reproduce :

- create a new input field and press play
- click inside the field and notice the caret is missing
- type something, try to select it and notice it doesn't work

*Note :
Seems to work fine in 5.1.

Comments (15)

  1. 7fac3e8b7cb80686e1f49d969b36679a?d=mm

    ssedlmayr

    Aug 11, 2017 04:35

    Why is this logged as fixed? It still occurs in Unity 5.6.1f1.

  2. A92d004b75f3dfbf98c2ef0fe8ef4231?d=mm

    biofish

    Nov 26, 2015 16:53

    I am on 5.2.3 and I have this issue.

  3. 5f6ebe40db48266a9ef959b5611f8602?d=mm

    Christoph_CH

    Nov 01, 2015 08:29

    But with 5.2.2f1 it seems to be ok again !!

  4. 5f6ebe40db48266a9ef959b5611f8602?d=mm

    Christoph_CH

    Oct 31, 2015 17:26

    Above steps to repoduce are still not working in Version 5.2.1f1 !?

  5. F83bcc607030068940b7bd939d5c9e1e?d=mm

    lodendsg

    Sep 24, 2015 11:22

    I have this effecting 3 of my input fields and any input field added to the same parent object yet I also have a number of input fields that work as expected.

    What of interest is I have tried
    - copying the working ones and using them in the parent object ... doesn't work
    - Creating new input field at design or run time doesn't work
    - The same input field dragged to a different UI parent ... works as expect

    I would simply work around this but the UI parent needs to be this fields parent
    I have noted that while the caret and highlight doesn't show up it does take input ... still not acceptable as I need it to conform to the same look, feel and functionality as the rest of the UI

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.