Search Issue Tracker

Not Reproducible

Votes

0

Found in

Issue ID

918667

Regression

Yes

Can't Re-Activate Unity license

Hub

-

Repro steps:

1. Open Unity
2. When greeted by "Unity license is not yet valid" press "Re-Activate"
3. a) Enter your Unity serial number and press next
b) Press Unity "Personal" and press next

Expected result: For Unity to activate the chosen license type
Actual result: Unity doesn't pass the Activation stage/Reverts back to choosing what license type to choose

Reproduced with: 2017.2.0a3, 2017.2.0a2, 2017.2.0a1(Sometimes, look at video)
Regression introduced in: 2017.2.0a1
Did not reproduce on: Everything else

Note:
The sequence in which you launch the editor MATERS for 2017.2.0a1 and 2017.2.0a3

Comments (26)

  1. Bff88bda6e0f8ec78c2ebc1299780bf4?d=mm

    personalme

    Jul 24, 2018 19:34

    SERPENTEAGLE, thank you, you saved so much time. Thanks, thanks, thanks!!!

  2. 848620b73ade9b64cd6aebc554f09e9d?d=mm

    breinbaasnl

    Jun 09, 2018 14:05

    Excellent answer by ipismai (dual boot Ubuntu)

  3. A245013f93b567af87a8e23d533414db?d=mm

    Decreationist

    Mar 21, 2018 23:17

    Ran into exactly this issue aswell, fresh install of windows 10, tried all the 2017.*-editions of Unity.

  4. 19fd02ebec7d75b4f7211d0642c28eac?d=mm

    anhminh-dinh

    Feb 13, 2018 17:43

    My solution was uninstall Unity completely, remove all AppData, ProgramData Unity folders. Reinstall.

    But my guess is just remove C:\ProgramData\Unity\Unity_lic.ulf file (rename it if u r not so confident).

    Of course u should set date time as previous replies.

  5. 4e0d0233f760970e4461f09c6e74b184?d=mm

    SerpentEagle

    Feb 12, 2018 21:09

    I faced the same issue today. I was able to fix it by going to my date and time settings (in Windows 10) and turning off and on the "Set time automatically" option. Apparently, my time was off by half an hour for some reason.

  6. 6ccdfa91a1ff1f27af26eb05540d79c6?d=mm

    nepoez

    Jan 10, 2018 08:09

    I changed my system clock to 5 days later then it works... but that's not cool

  7. 6ccdfa91a1ff1f27af26eb05540d79c6?d=mm

    nepoez

    Jan 10, 2018 07:56

    Same here, what the FAAck man... this is pissing me offf.

  8. A26fa93df524fc69884991ac6af756ea?d=mm

    LyolikM

    Jan 09, 2018 13:44

    @ipismai. Thanks, it worked for me.

  9. E62562b94cc1bfc32200164f8c95bb88?d=mm

    ipismai

    Dec 30, 2017 10:18

    I had the same problem today but was able to fix it.

    For me the issue the cause of the issue seemed to be that having a dual boot OS with Ubuntu and Windows 10 is messing with the system clock on the Windows side, making the time be multiple hours late from the real time.

    Adjusting the clock in Windows to the proper time resolved the issue. This may have something to do with the Unity licenses containing multiple very precise timestamps for the start and activation times of the license.

  10. D2143047a58a443b8945a5ad922c86fd?d=mm

    tanuj0092

    Dec 28, 2017 12:34

    Same issue is happening with me for all versions of Unity I install on my system. Stuck badly.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.