Search Issue Tracker

Fixed in 4.5.1

Votes

82

Found in

4.3.0f4

Issue ID

576670

Regression

No

Cannot logout from Mac if MonoDevelop is open

CodeEditors

-

To reproduce:
1. Have a MonoDevelop window open
2. Try restart/logout/shut down your Mac
3. Click trough any confirmation dialogs
4. Notice a dialog that says "The application MonoDevelop-Unity cancelled restart"
5. MD has no open dialogs and is not waiting for any confirmations
6. Clicking "Try again" just repeats the confirmation dialog and results in MonoDevelop canceling restart/logout/shut down

Comments (12)

  1. 03ad9a9ae40c06cf2aa971fb569f680a?d=mm

    crismuench

    Sep 05, 2018 20:24

    @blindeyedevelopment that worked!! thanks!

  2. 0dfa1b459c30fff93cdc326f05070366?d=mm

    BlindEyeDevelopment

    Jan 18, 2018 21:56

    I couldn't get the menu or right clicking in the dock to work for me, BUT, if you use the shortcut "command+Q" while Monodevelop is open, is works for me every time to close the program. It's definitely a bug that needs to be fixed though.

  3. 226a69a5754fc3eeff1689e81b5f7f66?d=mm

    catr.me

    Mar 06, 2014 01:29

    This is definitely a bug. This happens even if you haven't edited any files in MonoDevelop. This bug is not preventing people from losing work.

    I'm on Unity 4.3 + osx 10.9.1 if that matters.

    To reproduce:

    1) Start unity
    2) Open a script
    3) Close the monodevelop script window by pressing the red X button in the top left of the window
    4) Try to Quit monodevelop from the dock, this fails.
    5) Quitting monodevelop from the menu does work, however.

    I expected step 4 to actually quit monodevelop. There are no changed files, so nothing would be lost.

  4. 50fdb0782e8c50ea527809e31b01e351?d=mm

    sebrk

    Jan 24, 2014 11:13

    I cannot even close MonoDevelop by trying to quit it. The icon jumps on the dock and the app stays running. I have to force quit it every time.

  5. 9a5886b2613a4f976c0a764df006483a?d=mm

    oskargargas

    Jan 09, 2014 09:00

    I can confirm using 10.9.1and I do experience many others problems with currently shipped version.

    MonoDevelop shipped with Unity is hell outdated. 4.0.1 vs current 4.2.3.
    To all reading this comment I recommend voting for idea of being able to use any version of MonoDevelop/XamarinStudio with proper Unity plugins support.

    http://feedback.unity3d.com/suggestions/monodevelop-addin-instead-of-cu Let's make it hottest and most voted thread!

  6. C7b726d1919e127dd9de9dfee5f565dc?d=mm

    Frostbite23

    Dec 28, 2013 07:20

    I aggree, this issue is very irritating, than i have to force quit mono develop every time I restart or even shut down my mac!

  7. 77896e07df6191a9a96a35e3f0b1a745?d=mm

    pokemine29

    Dec 23, 2013 20:49

    unity wont even load says Unable to load mono library from "C:/Program Files (x86)/Unity/Editor/

  8. 4352434c3a514912c8a0d82693d6cfc1?d=mm

    iKonrad

    Dec 11, 2013 09:16

    Yeah very annoying bug. It just breaks the way that OSX works.

  9. 99cc12547377fdec39231922cd5ac49a?d=mm

    boriel

    Dec 09, 2013 12:27

    This is a nasty bug. If all code is already saved, Monodevelop should close (as Unity does) and let the mac shutdown normally. Previous monodevelop version worked correctly.

  10. Bb98e4392990b3490a59e3dcb047f75a?d=mm

    SunnyChow

    Dec 06, 2013 01:51

    There is always another way to avoid losing work. For example, making MonoDevelop auto cache the files in somewhere, or just ask me to save files when I am trying to turning off computer if there is any file not saved. It's very annoying to be block shutting down until i manually save and close all files.

    Sometimes I turn off my computer in a hurry and forget this issue. It makes my computer keep running whole night.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.