Search Issue Tracker

Not Reproducible

Votes

29

Found in

2017.1.0b4

Issue ID

909581

Regression

Yes

Building on top of old build while its output_log.txt is open causes build to fail

Build Pipeline

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 4Minor or cosmetic issue

Steps to reproduce:

1. Create new project
2. Build and run
3. Once resolution selection screen launches - close it
4. Navigate to _data folder located in same folder as build executable
5. open output_log.txt
6. Return to editor and do build and run to overwrite previous build
7. Build fails. Contents of previous build are deleted (.exe and all items that were in _data folder)

Not reproducible: 5.4.5p2

Reproduced with:
5.5.0f3 (has somewhat useful error: OperationCanceledException: Failed to prepare target build directory. Is a built game instance running?)
5.5.3p3 (no warning or error)
5.6.1f1 (no warning or error)
2017.1.0b4 (UnityEditor.BuildPlayerWindow+BuildMethodException: Build failed with errors.
at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (BuildPlayerOptions options) [0x001b9] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:162
at UnityEditor.BuildPlayerWindow.CallBuildMethods (Boolean askForBuildLocation, BuildOptions defaultBuildOptions) [0x00050] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:83 )

Comments (24)

  1. 461b1cf142145a88aa4dc0a6866e8447?d=mm

    benedictrasmussen

    Feb 04, 2018 16:24

    I was having this issue due to an upgrade recently. I had been using 2017.1.0f1 and upgraded to 2017.3.0f3. I did not uninstall 0f1, and found that depending on which shiortcut I used to open Unity I was opening different versions. The older version (0f1) was causing the issue for me. 0f3 appears to work fine.

    Personally I simply deleted the old version. No reason to keep two confusing versions around.

  2. 27352d36747f355d1c4720038be1059c?d=mm

    Ankshil

    Feb 02, 2018 13:00

    Build completed with a result of 'Failed'
    UnityEngine.GUIUtility: processEvent(Int32, IntPtr)

    UnityEditor.BuildPlayerWindow+BuildMethodException: 2 errors
    at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (BuildPlayerOptions options) [0x00207] in /Users/builduser/buildslave/unity/build/Editor/Mono/BuildPlayerWindowBuildMethods.cs:172
    at UnityEditor.BuildPlayerWindow.CallBuildMethods (Boolean askForBuildLocation, BuildOptions defaultBuildOptions) [0x00050] in /Users/builduser/buildslave/unity/build/Editor/Mono/BuildPlayerWindowBuildMethods.cs:83
    UnityEngine.GUIUtility: processEvent(Int32, IntPtr)

    ------------------------------------------------------------------------------------------------------------------------
    I had the same problem when I tried to build an app. I was using unity 2017.2.1f1
    I solved the problem by changing the tools in the sdk folder with the tools_r25.2.5

    Download this file online here - https://androidsdkoffline.blogspot.in/p/android-sdk-tools.html

    First just rename the tools folder already present in sdk root folder with toolsXXXX and then
    Unzip tools_r25.2.5 and copy its tools into the sdk root folder.

    Still, the error was there then I realised that the jdk version is not correct too. so download jd1.8 here - http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

    Download java kit 8u161 and then in Edit->Preferences ->External Tools
    Set these jdk1.8 path and sdk path

    It worked for me after that and I built my first app using Unity 3d
    I hope it works for you too.

  3. 3e34bbc2a0a2b147b426be32a19d15d4?d=mm

    anyadahalor

    Nov 20, 2017 13:54

    For anyone still struggling with this issue (I was), here is a possible solution.

    I had the problem when I changed version number in player settings. I reverted it and still didn't work.

    I saved both the scene and the project and it worked. So try saving the project and the scene (even if you closed unity before... I have done that, deleted .vs folder, to no avail)

  4. 7c3dc12aec9279f260ec75c1873d77c1?d=mm

    PucaPuca

    Nov 14, 2017 04:01

    LegalSin's fix below (aug17) worked for me. VisualStudio hidden folder (.vs) and project files causing conflicts. The build flowed correctly after I removed those.

  5. D7c4f60db729026f5af02311550c41bf?d=mm

    CjaywesTT

    Nov 09, 2017 09:45

    Is this fixed at all? Saying no voting due to it being solved, what's the solution? I seen somewhere someone hit reimport all assets and it worked for them but it just doesn't seem to be fix for something totally different. Went through all of Unity 2017's player options and didn't see anything out of the ordinary.

  6. 8ac89383273d876c9a39c795a3e0a595?d=mm

    alecsis

    Oct 31, 2017 21:05

    Hey guys, I had the same error, my problem was because I tried to make the android build inside the assets folder of the project. When I changed the folder path for the build it worked. Hope it helps you.

  7. 050fd89013e814b5e12f8647bbe0314e?d=mm

    claudioal

    Sep 25, 2017 15:09

    It deletes the temp folders, uninstalls Unity, deletes the Unity folders that are inside the hidden "AppData" folder and reinstalls Unity ...

  8. Ab12b6e21bf1ce0088d384a02c382a49?d=mm

    dcolwell634

    Aug 25, 2017 13:50

    Hey Guys,

    I was working with HoloLens and tried reinstalling Unity as a troubleshooting step. Upon reinstall, I was getting this error when doing a build. I changed the Scripting Backend to .NET in the Player/Other Settings section and this fixed it. Based on my own research I can only assume the other version (IL2CPP) was missing some dll's. I was getting another error in conjunction with this one, saying something about could not find analyitcs.dll. Either way, give this a shot guys. Maybe it will work for you too.

  9. C4eb9b5d1d2b71607e55ecd56f9fc395?d=mm

    LegalSin

    Aug 17, 2017 17:39

    Delete folder .vs and all Microsoft Visual Project file in your "Main Game" Folder
    Close Unity, restart and rebuild.

  10. Ed0a2a5df0362a833641d4420e68684a?d=mm

    satch88

    Aug 10, 2017 16:32

    UnityEditor.BuildPlayerWindow+BuildMethodException: Build failed with errors.
    at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (BuildPlayerOptions options) [0x001b9] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:162
    at UnityEditor.BuildPlayerWindow.CallBuildMethods (Boolean askForBuildLocation, BuildOptions defaultBuildOptions) [0x00050] in C:\buildslave\unity\build\Editor\Mono\BuildPlayerWindowBuildMethods.cs:83
    UnityEditor.HostView:OnGUI()

    I have the same error. Any Fix for this ?
    Thanks in advance...

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.