Search Issue Tracker

Fixed in 1.0.0-preview.19

Votes

19

Found in [Package]

1.0.0-preview.18

Issue ID

1068985

Regression

No

AR Camera does not work with Video Player on ARCore

Package: ARCore

-

Copied from https://github.com/Unity-Technologies/arfoundation-samples/issues/7

"
I tried out AR Foundation a little by placing a plane with a video player in the SampleScene.
It worked as expected on iOS, but on Android I faced a problem:

The video gets rendered through the camera feed, as seen in this video: https://www.dropbox.com/s/05zsjpsx8fzm925/Screen%20recording%20AR%20Foundation.mp4?dl=0

I'm using Unity version 2018.1.5f1.
"

Comments (16)

  1. FlashyGoblin

    Aug 24, 2018 17:00

    Please fix.

  2. vaccaroryot

    Aug 22, 2018 22:44

    This is also a problem using AVPro rendering to a material (e.g. a tv screen)

  3. vl4dimir

    Aug 21, 2018 18:03

    Yes, it seems like it.

    BTW, I see that the bug has been classified as "Severity: 3 - Workaround is possible" – is there a known workaround? I couldn't find one and I've spent hours on this thing.

  4. Privateer

    Aug 21, 2018 10:49

    It seems as if the AR camera and the video player are fighting about who gets to render the back plane.

  5. Privateer

    Aug 21, 2018 10:33

    Also happens to me, using 8th Wall's SDK. But it doesn't happen when I use the remote in play mode.

  6. vl4dimir

    Aug 20, 2018 15:05

    In addition to using Unity's built-in VideoPlayer component, I've also tried using UMP Pro and its Native, libVLC, and Exo video plugins. All four approaches produce the same result (as described above), so it's probably tied to the way ARFoundation is handling the device's video camera feed. Let me know if I can help with fixing this one, it's pretty much a show stopper.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.