Search Issue Tracker

Fixed

Fixed in 2021.3.30f1, 2022.3.7f1, 2023.1.8f1, 2023.2.0b4, 2023.3.0a1, 2024.1.0a1

Votes

9

Found in

2021.3.28f1

2022.3.2f1

2023.1.0f1

2023.2.0a19

2023.3.0a1

2024.1.0a1

Issue ID

UUM-40891

Regression

Yes

[Android] Unity prompts for an update to API Level 36 when API Level 34 is used to build for Android

--

-

Reproduction steps:
1. Open the attached project “SDKProject”
2. Select API Level 34 in “Project Settings/Player/Other settings/Target API Level”
3. Build for Android
4. In the shown pop-up window select “Update Android SDK”
5. Observe the build process

Expected result: The building process proceeds without asking for an Update to API Level 36
Actual result: Build failure

Reproducible with: 2022.2.0a14, 2022.3.2f1, 2023.1.0f1, 2023.2.0a19
Not Reproducible with: 2021.3.27f1, 2022.2.0a13

Reproducible on: Intel macOS 13.3.1

Note: API Level 36 does not exist the highest released so far is 34.

Comments (6)

  1. richardgomes7d

    Jan 05, 2024 20:26

    Changing the AndroidTargetSdkVersion and the AndroidMinSdkVersion properties in the ProjectSettings.asset from 36 to 34 worked for me.

  2. gamer2300

    Dec 12, 2023 23:46

    Same problem on 2022.3.5f1 solution given by fenriquez is not valid. On sdk manager all is instaaled (AndroidTargetSdkVersion 34...) no one solved this?

  3. vlad1p

    Nov 01, 2023 08:02

    Why are you ignoring the problem?
    When you click Update Android SDK, the change in AndroidTargetSdkVersion: ** is not applied, and the value is returned to 36

    I work through the admin profile
    Unity 22.3.5f1

  4. nhftk

    Aug 29, 2023 20:45

    Running into this problem too.. I tried searching it up but almost no results, is there any solution to this? im building to android on 2022.2.2f1

  5. Trigshady

    Aug 19, 2023 14:37

    I have same issue with Unity version 2022.3.4f1 when I target android API level 34, it tries to install API Level 36 (which doesn't even exist at all), I have tried previous suggested workaround by FENRIQUEZ by changing AndroidTargetSdkVersion from 36 to 34 in ProjectSettings.asset, but that doesn't help it looks like Unity just generates new PorjectSettings.asset file during build and overrides this value back to 36, so there is still on going issue with this. I'm working on MacMini M1 if that's any relevant..

  6. fenriquez

    Jul 10, 2023 23:50

    In the file ProjectSettings.asset exist the AndroidTargetSdkVersion property with the value 36, change for 34 save file, and build.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.