Search Issue Tracker

Fixed in 2019.2

Fixed in 2019.1

Votes

0

Found in

2019.1.0a14

Issue ID

1118921

Regression

Yes

[Android] Release build fails with an error "Keystore was tampered with, or password was incorrect"

Mobile

-

Steps to reproduce:

1) Open Unity Hub and create a new project
2) Switch Platform to Android in the Build Settings
3) Go to Player Settings> Publish Settings
4) Click on Keystore Manager button and create a new Keystore
5) Fill all the details in the Keystore Manager window and click on Add Key button
Note: Confirmation window will pop
6) Select Yes button to set them as your Project Keystore and Project Key
7) Go to Build Settings and press Build button
Note: Error will appear in the building process:
Failed to read key keystorebugfortesting from store "C:\Users\Ernestas\Downloads\KeystoreBugForTesting.keystore": Keystore was tampered with, or password was incorrect

Expected result: Release build should not fail to build
Actual result: Release build fails to build

Reproduced with
2019.1.0a14, 2019.1.0a15, 2019.2.0a1

Not reproduced with:
2018.3.3f1, 2019.1.0a13

Regression since:
2019.1.0a14
------------------------
Fixed in:
2019.2.0a15

Comments (11)

  1. C6f5a7134fc9e6b946c2630280dc77de?d=mm

    kdbruyne11

    Sep 20, 2019 10:33

    Thanks for the useful information. This is the best website I never seen in recent times. Visit this walmart login guide website https://walmartone.onl and go through the blog

  2. C9c774111ecc06a0cef13bd243405a46?d=mm

    JohnOkleberry

    Aug 09, 2019 01:02

    Does anyone know the protocol when an issue is incorrectly marked fixed?

  3. C9c774111ecc06a0cef13bd243405a46?d=mm

    JohnOkleberry

    Aug 08, 2019 23:02

    Confirmed as others have stated. Upgraded to 2019.2.0f1 and this issue still prevents builds.

  4. C9c774111ecc06a0cef13bd243405a46?d=mm

    JohnOkleberry

    Jul 31, 2019 21:29

    Experiencing this issue with 2019.1.5f1. Have been searching forums and trying various supposed solutions without any success. Have had an update for my game for a few weeks now and can't upload any changes because of this error.

  5. F35bef3b1c25fe07a4aa02188615fa62?d=mm

    SplashFoxGames

    Jul 16, 2019 13:34

    Experiencing this issue in 2019.2.b9 when opening a project done in 2019.2.a14

  6. 0061cc94d3dd349173e6f86c9112b18c?d=mm

    roykoren

    Jun 11, 2019 13:14

    I don't know why exactly, but it is probably connected somehow with insufficient space on disk.
    So I solved this issue by removing files from 'C://' (Had less than 150MB free). that's it.

  7. 430deb22b5523cbe0ec6aa4f7fc35c19?d=mm

    SentreStage

    May 08, 2019 00:45

    Still not fixed in 2019.2.0a14

  8. 32eb808310a4859e866a6830ec6697a9?d=mm

    nathanhawthorne12

    Apr 19, 2019 07:19

    Still not fixed, I can open my keystore fine via Java and or keystore explorer (Seperate application) but I always get an invalid password when selecting the keystore via Unity 2019.1.0f2. Dont really want to upgrade to beta to fix this. Any ideas?

  9. 5c47876f94f10d1acc9929322a180f04?d=mm

    WILEz1975

    Apr 07, 2019 22:44

    Same error in 2018.2.2f1

  10. 244c8014d52ea476cae552ab0532f847?d=mm

    Dazo1985

    Apr 04, 2019 18:43

    Yes this is not fixed!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.