Search Issue Tracker

Fixed in 2020.1.X

Fixed in 2019.3.X

Votes

14

Found in

2019.3.0f1

2020.1.0a14

Issue ID

1201529

Regression

Yes

[Android] Editor shows that the Android NDK is not recommended even though it is installed from the Hub

Mobile

-

How to reproduce:
1. Install the newest 2019.3 or 2020.1 Unity version from the hub
2. Include Android support > "Open JDK", "SDK and NDK" modules
3. Create and open a new Project
4. Go to Preferences > External Editors
5. Make sure "Android NDK installed with Unity" checkbox is checked

Expected Behaviour: No warnings since Editor installed the NDK and SDK itself
Actual Behaviour: Warning occurs telling that there is no recommended NDK version and prompts you to install one from Hub

Reproducible with: 2019.3.0f1, 2020.1.0a14
Not reproducible with: 2019.2.14f1
Could not test with: 2017.4 and 2018.4 streams as Hub does not have an option to download NDK and SDK for those streams

Note: IL2CPP build fails due to this issue.

WORKAROUND:
Please manually select NDK in
\2019.3.0f1\Editor\Data\PlaybackEngines\AndroidPlayer\NDK\android-ndk-r19
instead of
\2019.3.0f1\Editor\Data\PlaybackEngines\AndroidPlayer\NDK\

Comments (9)

  1. futurlab_peterh

    Sep 02, 2021 15:23

    This is still happening on 2020.3.17f1.

    This seems to be related to using Unity Hub beta - installs done by it had no SDK, OpenJDK or NDK subfolders (or didn't have all files). I reverted to the latest Unity Hub production version (2.4.5), tried to install Unity again, and then it had all Android files in the right place.

  2. emmanuelvincen88

    Dec 17, 2020 09:19

    The free apps for Android today are offered a lot on the Mod apk sites today. You can find them anywhere.

  3. wesp_s

    Dec 19, 2019 00:15

    Updating Unity hub to v2.2.2 fixed the problem for me.
    Tested with the following:
    - 2019.2.16
    - 2019.3.0f3

  4. FURKANKAHVECI

    Dec 16, 2019 11:14

    2019.2.13
    2019.2.16

  5. Miguel_LZ

    Dec 12, 2019 11:11

    This needs to be addressed ASAP. I can't believe there's a fix being tested for 2020.1 but just "planned" for 2019.3, which comes way earlier. Can't see the point of including the brand new Device Simulator in 2019.3 and then have a basic Android build thing broken.

  6. Ghosthowl

    Dec 01, 2019 14:35

    I also have this issue in 2019.3.0f1 but unlike OP, also had the issue in 2019.2.13f1 and 2019.2.14f1. Moxdiamonds workaround solves the issue.

  7. egavi3d

    Dec 01, 2019 09:27

    still not working on 2919.3.0f1
    after setting manually the path of the NDK installed with unity hub, the App is built but it crashes when opening in Android.

  8. MoxDiamond

    Nov 30, 2019 04:12

    The work around I had to do in order to build successfully was to edit the path listed under External Tools. I had to uncheck "Android NDK installed with unity" and add the folder name of the NDK to the original path (for mine, on a MacBook, it was /Applications/2019.2.14f1/PlaybackEngines/AndroidPlayer/NDK/android-ndk-r16b)

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.