Search Issue Tracker

Fixed in 2021.2.X

Fixed in 2019.4.X, 2020.3.X, 2021.1.X

Votes

37

Found in

2020.1.3f1

Issue ID

1272592

Regression

Yes

[Android] Build fails when there are 680 or more files in the Streaming Assets folder

Mobile

-

Reproduction steps:
1. Download and open the user-submitted project "BuildStreamingAssets2020.zip"
2. Build the project

Expected result: Build is successful
Actual result: Build fails

Reproduces on: 2020.1.0b14, 2020.1.6f1

Does not reproduce on: 2019.4.11f1, 2020.1.0b13, 2020.2.0a1, 2020.2.0b3

Error message:
> A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$ActionFacade

UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr, Boolean&)

Notes:
Does not reproduce on iOS
____
This is a problem outside of Unity, reported to Android Studio:
https://partnerissuetracker.corp.google.com/issues/177236664

A workaround would be to use custom Gradle files and specify the file extensions. By default we specify few extensions and list all the files from streaming assets. Instead of listing streaming assets you can specify the file extensions. The downside with that is that all files with such extension will be uncompressed including those outside of streaming assets.

  1. Resolution Note (fix version 2021.2):

    Fixed in 2022.1.0a10

  2. Resolution Note (fix version 2021.2):

    Fixed in 2021.2.0b13

  3. Resolution Note (fix version 2021.1):

    Fixed in 2021.1.9f1

  4. Resolution Note (fix version 2020.3):

    Fixed in 2020.3.13f1

  5. Resolution Note (fix version 2019.4):

    Fixed in: 2019.4.32f1

Comments (27)

  1. missli93

    Sep 01, 2022 02:17

    I have the same problem with Unity 2020.3.24f1.
    below is my solution
    in \2020.3.24f1c1\Editor\Data\PlaybackEngines\AndroidPlayer\Tools\
    find launcherTemplate.gradle mainTemplate.gradle files ,and
    origion content:
    aaptOptions {
    noCompress = ['.ress', '.resource', '.obb'] + unityStreamingAssets.tokenize(', ')
    my changed:
    aaptOptions {
    noCompress = ['.ress', '.resource', '.obb', ''] + unityStreamingAssets.tokenize(', ')
    add , '' after '.obb'

  2. songguangze

    Feb 08, 2022 10:29

    Thanks TIANZHIZHI

  3. anycolourulike

    Oct 05, 2021 11:55

    Not fixed in 2020.3.x

  4. anycolourulike

    Oct 05, 2021 11:55

    Still an issue

  5. MarcSpraragen

    Jun 28, 2021 20:42

    I'm doubting Unity's "Fixed" updates.

    Version 2020.3.13f1 is not apparently available to download. And, we are using Unity 2020.1.10f1 and getting this error

  6. YangEGG

    May 31, 2021 15:32

    Thank you TIANZHIZHI.
    it works for me!!

  7. Koji-Nakamaru

    May 18, 2021 02:58

    I've solved the issue by applying the following diff:

    --- ./2020.3.6f1/PlaybackEngines/AndroidPlayer/Tools/GradleTemplates/launcherTemplate.gradle.bk 2021-05-06 17:45:29.000000000 +0900
    +++ ./2020.3.6f1/PlaybackEngines/AndroidPlayer/Tools/GradleTemplates/launcherTemplate.gradle 2021-05-06 17:46:10.000000000 +0900
    @@ -27,7 +27,7 @@
    }

    aaptOptions {
    - noCompress = ['.ress', '.resource', '.obb'] + unityStreamingAssets.tokenize(', ')
    + noCompress = ['.ress', '.resource', '.obb', '.bundle']
    ignoreAssetsPattern = "!.svn:!.git:!.ds_store:!*.scc:.*:!CVS:!thumbs.db:!picasa.ini:!*~"
    }**SIGN**

  8. Koji-Nakamaru

    May 18, 2021 02:54

    I've solved the issue by applying the following:
    https://gist.github.com/KojiNakamaru/c99b0c092a010b7adfa64d87ab88018e

  9. Alanmars0214

    May 14, 2021 07:11

    I have the same issue with Unity 2019.4.20f1c1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.