Search Issue Tracker

Fixed in Unity 5.5.0

Votes

2

Found in

5.4.1p3

Issue ID

851455

Regression

Yes

[Windows] Windows.Speech.DictationRecognizer results in an Unknown Error

Editor - Other

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 2No workaround

Steps to reproduce:
1. Open User's attached project
2. Open scene "ConfigurationTest"
3. Enter Play mode
4. Press button "Dictation Recognizer Start"

Result: Dictation Recognizer doesn't work. Error in the Console: Dictation completed unsuccessfully: UnknownError.
UnityEngine.Debug:LogErrorFormat(String, Object[])
MainConfiguration:<OnGUI>m__2(DictationCompletionCause) (at Assets/Scripts/MainConfiguration.cs:91)
UnityEngine.Windows.Speech.DictationRecognizer:DictationRecognizer_InvokeCompletedEvent(DictationCompletionCause)

Reproduced with: 5.6.0a3, 5.5.0b11, 5.4.2f1.
Not reproduced with: 5.3.7p1 (due to errors in the console).

Comments (14)

  1. 186705cd9b2ee1259be9b722161d3fc7?d=mm

    simonej33

    Apr 21, 2017 02:59

    Still not fixed!

  2. 2f221f83141ac1d84c02dbf0e2615798?d=mm

    Rarceth

    Apr 10, 2017 01:47

    Not fixed in 5.6. Cmon guys, you're doing so well!

  3. 9275aa0018ba900ea991a5c660c7d799?d=mm

    Meteoropolis

    Feb 25, 2017 12:45

    Defiantly not fixed in 5.5.0f3 which is really frustrating because it would be such a useful tool to use.

    Please, please fix it Unity or get Microsoft to fix it

  4. 36d6391db7aa230fab6b8e1ace13a0bd?d=mm

    Hodgson_SDAS

    Feb 20, 2017 22:27

    Not fixed.

  5. 0cae64c388820bbee3b108b19d5ebf40?d=mm

    CommanderThrawn

    Feb 07, 2017 18:56

    I've been in contact with Unity, and they claim it's the fault of Windows and they will never fix it (this "fix" is just better debug output). The solution is to downgrade windows (or upgrade to the next version when it comes out), as 1607 is broken. The problem is, any users on the Anniversary Edition won't be able to use your stuff.

    Our solution, for those who really need this, is to spin the voice recognition off into a separate process, and send the inputs back into Unity.

    Good luck!

  6. Dd63fd94b5bab3a64b1f9558fc0ab46b?d=mm

    jdepascale

    Jan 27, 2017 20:22

    This is definitely not fixed, confirming still broken for 64 bit, as noted by others.

  7. F9b52d3c59ca1f2a8ac44959d7aecda2?d=mm

    icecrusher42

    Jan 26, 2017 09:53

    I am also running into this issue on 5.5.0f3. Building for 32 bit will allow the dictation to work, but 64 bit builds (or the 64 bit Unity editor) do not work. I have heard that others are able to get the dictation to work in-editor when using the 32 bit build of Unity. Additionally, it sounds like an update for Windows 10 around October 2016 caused this issue. See the last post of this link for more info: https://forum.unity3d.com/threads/unity-voice-recognition-issues.435038/

  8. 52d039d5d5d7f28dbed71c033e247774?d=mm

    superjayman

    Jan 24, 2017 05:02

    The issue is still not fixed! fails to work with x86_64 builds???

  9. 133d6034f5670b4b949a4f3f043bf9f1?d=mm

    BAaoo

    Jan 23, 2017 06:13

    Been waiting since October.. pleaseee

  10. C32c6e65d254928191806b9129e763d4?d=mm

    lharper

    Jan 18, 2017 19:00

    I'm using 5.5.0f3 and this is still unresolved.

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.