Search Issue Tracker

Won't Fix

Votes

0

Found in

5.6.0b8

Issue ID

893955

Regression

Yes

[UI] Unknown Mixed bake mode in LightModeUtil.MapSettings() Error

uGUI

-

This error shows up when upgrading a project. The error consistently occurs when opening the project attached below.

Unkown Mixed bake mode in LightModeUtil.MapSettings()
UnityEditor.LightingWindow:OnEnable()
UnityEditorInternal.InternalEditorUtility:LoadSerializedFileAndForget(String)
UnityEditor.WindowLayout:LoadWindowLayout(String, Boolean)

Steps for reproduction:

1) Open the project attached below
2) Open the scene “s3"
3) Bake the scene or click on the lighting window
4) Observe the errors in the console (screenshot attached below)

Notes:
- Regression introduced in 5.6.0b8
- Workaround solution is to delete Library folder and open the project again
- Issue occurs both on mac and windows

Comments (8)

  1. E16dc2a8478103b12d19e2c26ad2ca76?d=mm

    EbonyGaunt

    Sep 19, 2019 07:30

    Unity issue tracker is the page that deals with the tracking and the tracker of different ways that can’t be fixed for them. The module that is described here is mentioned in the link of https://www.techshout.com/internet/2019/20/how-american-sanctions-on-huawei-will-affect-university-students/ to get the map sitting and the error that is created in the situational story.

  2. 9eae15b6931a4b898e809ad285860874?d=mm

    barkazzaz

    Dec 19, 2018 20:49

    Here's how to resolve (worked for me at least):
    Window->Lightning->Settings:
    click on the settings icon (looks like a gear icon) -> reset

    That's the only way it was resolved and I could re-edit my lightning.
    Hope it helps someone as I couldn't find this particular answer anywhere..

  3. F4f819806c1c6a1dab5add1c3c8755dd?d=mm

    twobob

    Jul 25, 2018 18:38

    RKeown3Ds comment worked for me too.

    Deleting the library does not work.

    This occurs when stupidly rolling back versions too...

  4. Dbb22b52ce5fe9a512fda689d026bb1f?d=mm

    hejaaa

    Apr 06, 2018 10:44

    Won't Fix? You are serious? Re-enabled settings is madness workflow :D

  5. A6861067a00d231ecbe033fcab277a01?d=mm

    KrankyBoyGames

    Apr 02, 2018 21:30

    RKEOWN3D's comments solved the issue for me.

  6. 30473a715d509120773aff30a603df71?d=mm

    Artifact-Games

    Jan 25, 2018 14:49

    Thanks to RKEOWN3D for the workaround. It worked after doing that convoluted step.

  7. A0a2b4c79e7ca8dc486ee5f36bb2fb0d?d=mm

    RKeown3D

    Nov 25, 2017 02:31

    I had this occur after I imported the Winter Ground Package from NatureManufacture into my project. i was able to get around this by unchecking Realtime Global Illumination, then Generate Lighting, and then re-enabling the Realtime Global Illumination, and then rebuilding Generate Lighting again.

  8. 91b57cdc750353d8bf210a363376c338?d=mm

    Mithri1

    Aug 16, 2017 08:44

    This is not resolved, and deleting library doesn't work. Since it comes back. You should have a closer look at this one. For it only happens when I use OnGUI with buttons (so far)

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.