Search Issue Tracker

Fixed in Unity 2017.3.0f3

Votes

9

Found in

2017.1.0f3

Issue ID

937499

Regression

Yes

Unity doesn't start when blocked by firewall or when internet connection is poor

Hub

-

-

Priority: 5Not yet prioritized for a release

-

Severity: 1Crash, freeze, data loss, work stops

1. Get FirewallAppBlocker, or anything like it, or do it manually through win firewall
2. Search for all .exe files with win search, select them all, drag on Fab, or manually add them all to windows firewall and block
3. Launch unity, close, repeat until it fails to load (mine fails on second launch - first loads ok, then fails)

It fails either to a white screen with a loadbar, or (a new one) to just a black window.

Editor log:

LICENSE SYSTEM [2017731 13:13:24] No start/stop license dates set

LICENSE SYSTEM [2017731 13:13:24] Next license update check is after 2017-07-31T18:59:12

Built from '2017.1/release' branch; Version is '2017.1.0f3 (472613c02cf7) revision 4662803'; Using compiler version '160040219'
OS: 'Windows 7 (6.1.7600) 64bit' Language: 'en' Physical Memory: 16325 MB
BatchMode: 0, IsHumanControllingUs: 1, StartBugReporterOnCrash: 1, Is64bit: 1, IsPro: 0

COMMAND LINE ARGUMENTS:
D:\u2017.1\Editor\Unity.exe
[CEF] undefined in file:///C%3A%2FUsers%2Falex%2FAppData%2FRoaming%2FUnity%2FPackages%2Fnode_modules%2Funity-editor-home%2Fdist/assets/unity-editor-home.js at line 39
Error loading https://api.unity.com/v1/oauth2/authorize?client_id=launcher&display=launcher&locale=en_US&response_type=code&redirect_uri=launcher://unity/C%3A%2FUsers%2Falex%2FAppData%2FRoaming%2FUnity%2FPackages%2Fnode_modules%2Funity-editor-home%2Fdist/index.html#/login

(Filename: C:\buildslave\unity\build\Editor/Platform/Interface/NativeWebViewWindow.cpp Line: 51)

There is more info in this forum post:

https://forum.unity3d.com/threads/blocking-unity-from-internet.485934/

Comments (12)

  1. 7d6c7979b3e6126482601db51071d6dd?d=mm

    gapiso

    May 04, 2018 01:53

    Hi,
    It happens when a new java version is released, or windows is updated and the pc has to be restarted. I disable every option for the firewall (domain network, private network, and public network goes off) and the project opens normally. Then I restore the firewall settings and unity can open other projects again.
    (Using unity 2017.3.0f3 64 bit on a Windows 10 Home computer)

  2. Fadf5cd8776c5bb6e6bb3c507ac5a434?d=mm

    savely00

    Apr 24, 2018 21:30

    Same with Unity Unity 2018.2.0b1 (64-bit).
    Setting up noproxy from UNITY_NOPROXY environment variable. Setting to: 127.0.0.1,localhost

  3. 9c0b1cfbabbbb232a59ae7b5ecba903d?d=mm

    sysmaya

    Jan 21, 2018 05:34

    In Unity 2017.3.0f3 Same.
    Dont connect to Store, Services, none.

  4. D5cb7e4149054d7769f194a56571cbd4?d=mm

    zeltaCN

    Jan 03, 2018 14:46

    Same with Unity 2017.3.0f2(64bit),This is a big problem,I can not get it to work by any other means

  5. 35fbb3df53d718638f6947579567e777?d=mm

    happan

    Dec 16, 2017 20:47

    Sameeee.... :/

  6. Ae7fd44b97637dedc14c65b5db75c73c?d=mm

    opdenis

    Dec 15, 2017 17:50

    Same with Unity 2017.3.0f2

  7. A9537737e262f2f32c2d64e54025b27c?d=mm

    koeiandy

    Nov 22, 2017 03:29

    Same problem with 2017.2.0f3. It would freeze Unity Editor and force me to close the editor.

  8. 9dcc67f444e11c11c4d4823c8ad2d6fc?d=mm

    jwvanderbeck

    Nov 02, 2017 20:20

    This is a huge issue for our studio as we don't have internet connections due to MPAA restrictions.

  9. 425e1fcffa00a418b92dba9fda9ad2ce?d=mm

    kamranh555

    Oct 05, 2017 13:13

    I found a strange way of getting it work. When unity gets stuck on loading bar I turn off my internet, it gives me an option of working offline I click that. Unity stucks again, then I close unity and launch it again and this time it worked fine. But I have to repeat this process everytime because on next launch it brings me back to the original problem.

  10. 03456367121af073cab3811fdf86e4ce?d=mm

    dormouse

    Oct 05, 2017 09:19

    Hello, please fix this issue. Since yesterday (04/10/2017), we could not open any projects, even create new one is always (not responding). We have to manually kill the session. We are in Unity3D 2017 1.1.f1 in MacOS Sierra 10.12.6. The only solution we found is: disable network. then open unity without any probleme. Once here's the internet connection, we could not open Unity3D anymore. Please fix is. It seems some issue on this server ? ( https://public-cdn.cloud.unity3d.com/config/production) Please take a look at these log files:

    [with internet connect, failed to open]
    COMMAND LINE ARGUMENTS:
    /Applications/Unity/Unity.app/Contents/MacOS/Unity
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [CEF] undefined in file:///%2FUsers%2FAdmin%2FLibrary%2FUnity%2FPackages%2Fnode_modules%2Funity-editor-home%2Fdist/assets/unity-editor-home.js at line 39
    2017-10-05 11:01:45.630 Unity Helper[6342:76795] XType: failed to connect - Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.fonts was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.fonts was invalidated.}
    2017-10-05 11:01:45.630 Unity Helper[6342:76795] Font server protocol version mismatch (expected:5 got:0), falling back to local fonts
    2017-10-05 11:01:45.630 Unity Helper[6342:76795] XType: unable to make a connection to the font daemon!
    2017-10-05 11:01:45.630 Unity Helper[6342:76795] registering /System/Library/Fonts/*, /System/Library/Fonts/Base/*, and /Library/Fonts/* locally
    IsTimeToCheckForNewEditor: Update time 1507193961 current 1507194107
    /Users/Admin/Desktop/Unity3D Projects/RHEnvi
    Loading GUID <-> Path mappings...0.000034 seconds
    Loading Asset Database...0.005305 seconds
    Audio: FMOD Profiler initialized on port 54900
    AssetDatabase consistency checks...0.023443 seconds
    Refreshing native plugins compatible for Editor in 1.61 ms, found 0 plugins.
    Preloading 0 native plugins for Editor in 0.00 ms.
    Initialize engine version: 2017.1.1f1 (5d30cf096e79)
    GfxDevice: creating device client; threaded=1
    Metal: Editor support disabled, skipping device initialization

    [without internet connection, no problem!]
    COMMAND LINE ARGUMENTS:
    /Applications/Unity/Unity.app/Contents/MacOS/Unity
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    [warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
    Request timed out while processing request "https://public-cdn.cloud.unity3d.com/config/production", HTTP error code 0
    .[UnityConnect] Request timed out.
    [CEF] undefined in file:///%2FUsers%2FAdmin%2FLibrary%2FUnity%2FPackages%2Fnode_modules%2Funity-editor-home%2Fdist/assets/unity-editor-home.js at line 39
    2017-10-05 11:04:40.095 Unity Helper[6421:78612] XType: failed to connect - Error Domain=NSCocoaErrorDomain Code=4099 "The connection to service named com.apple.fonts was invalidated." UserInfo={NSDebugDescription=The connection to service named com.apple.fonts was invalidated.}
    2017-10-05 11:04:40.095 Unity Helper[6421:78612] Font server protocol version mismatch (expected:5 got:0), falling back to local fonts
    2017-10-05 11:04:40.095 Unity Helper[6421:78612] XType: unable to make a connection to the font daemon!
    2017-10-05 11:04:40.095 Unity Helper[6421:78612] registering /System/Library/Fonts/*, /System/Library/Fonts/Base/*, and /Library/Fonts/* locally
    IsTimeToCheckForNewEditor: Update time 1507193961 current 1507194284
    /Users/Admin/Desktop/Unity3D Projects/RHEnvi
    Loading GUID <-> Path mappings...0.000034 seconds
    Loading Asset Database...0.006072 seconds
    Audio: FMOD Profiler initialized on port 54900
    AssetDatabase consistency checks...0.024006 seconds
    Refreshing native plugins compatible for Editor in 1.71 ms, found 0 plugins.
    Preloading 0 native plugins for Editor in 0.00 ms.
    Initialize engine version: 2017.1.1f1 (5d30cf096e79)
    GfxDevice: creating device client; threaded=1
    Metal: Editor support disabled, skipping device initialization

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.