Search Issue Tracker

Fixed in 2020.2

Votes

13

Found in

2019.3.0f1

2019.4

2020.2

Issue ID

1258876

Regression

No

[New Input System] Keyboard input is not detected in the Input Field when built on WebGL

WebGL

-

How to reproduce:
1. Open user's attached "InputFieldTestProject.zip" project
2. Go to File -> Build Settings
3. Make sure the platform is set to WebGL
4. Press Build
5. Write some text in the Input Field in the browser

Expected result: Text appears in the Input Field, keyboard input (eg. CTRL+V) is registered
Actual result: No text appears in the Input Field, keyboard input (eg. CTRL+V) is not registered

Reproducible with: 0.2.10-preview (2019.4.2f1), 1.0.0 (2020.1.0b14, 2020.2.0a17)
Could not test with: 2018.4.24f1 (New Input System not supported)

Notes:
- The issue is not reproducible in the Editor and on Windows, Mac build
- The issue is not reproducible with the Old Input System

  1. Response avatar

    Resolution Note (fix version 2020.2):

    Fixed in: 2021.1.0a1

    Note:
    The WebGL input system has been fixed so keyboard events will be sent to GUI controls with the new input system

Comments (7)

  1. 570bf9778540c63032d6741922dde0e3?d=mm

    outoftunegames

    Oct 23, 2020 17:19

    Just ran into this problem when updating to the new input system. It looks like the fix is in 2020.2, why not have it in an updated 2020.1.x?

  2. 98f653c355fce84b905bb583fea72b70?d=mm

    Krahgnatokz

    Oct 03, 2020 20:29

    Had this issue as well. Using Unity 2020.1, Input System 1.0.0

    Found a temporal solution here: https://forum.unity.com/threads/textmeshpro-input-field-new-input-system-webgl-no-work.926396/

    Edit -> Project settings -> Player -> WebGL Settings -> Other Setting -> Active Input Handling and setting that option to "Both" instead of "Input System Package (New)

  3. 98f653c355fce84b905bb583fea72b70?d=mm

    Krahgnatokz

    Oct 03, 2020 20:05

    Same issue here.
    Using Unity 2020.1, Input System version 1.0.0 and TextMesh Pro 3.0.1.
    Tested with scenes that had nothing but a TextMeshPro Input Field and the normal Input Field. Neither worked.

  4. F6357b4ada3a718c9c6378d89bb6f451?d=mm

    jbertra

    Aug 19, 2020 11:46

    I am having the same issue where characters are not displaying in the input fields for my WebGL builds. Both the standard and Text Mesh Pro input fields are affected, but they work fine in the editor.

    Versions:
    Unity 2020.1.2f1
    Input System 1.0.0
    Text Mesh Pro 3.0.1

  5. 8712d413d98434bf3718274be5361908?d=mm

    TaranisElsu

    Aug 04, 2020 14:03

    I just installed the latest Unity 2019 and made sure all the packages were up to date and the problem still exists.

    Versions:
    Unity 2019.4.6f1
    "com.unity.textmeshpro": "2.1.1",
    "com.unity.inputsystem": "1.0.0",

  6. 8712d413d98434bf3718274be5361908?d=mm

    TaranisElsu

    Aug 04, 2020 12:32

    I have the same issue, and the issue @ROBSCHERER123 mentioned with the mouse scroll wheel scrolling really really slow.

    I added:
    #if UNITY_WEBGL && !UNITY_EDITOR
    zoom *= 100f;
    #endif
    to my code to work around the scroll issue for now, but I have not found a workaround for the Input Fields not working. I did notice that arrow and Home/End keys move the cursor around, but nothing seems to happen when typing letters or numbers (even from the numpad).

  7. 8780c197511308de65b1e70887091cdd?d=mm

    robscherer123

    Jul 23, 2020 14:54

    I am having this issue as well. Also adding that related to this is the mouse scroll wheel and using ScrollRect's in game. If you use the new input system and publish to WebGL, the scroll rect will scroll extremely slow. However it will work fine in the editor.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.