Search Issue Tracker

Fixed

Votes

20

Found in

Issue ID

1204148

Regression

Yes

"The value of \"byteLength\" is out of range" error is thrown in the Hub logs

Hub

-

{"level":"error","message":"Unhandled promise rejection, reason: The value of \"byteLength\" is out of range. It must be >= 1 and <= 6. Received 8\n\tstack RangeError [ERR_OUT_OF_RANGE]: The value of \"byteLength\" is out of range. It must be >= 1 and <= 6. Received 8\n at boundsError (internal/buffer.js:58:9)\n at Uint8Array.readUIntLE (internal/buffer.js:80:3)\n at WindowController._sendMainWindowHandleData (C:\\Program Files\\Unity Hub\\resources\\app.asar\\src\\services\\localIPC\\controllers\\window.js:104:30)\n at WindowController.show (C:\\Program Files\\Unity Hub\\resources\\app.asar\\src\\services\\localIPC\\controllers\\window.js:53:12)\n at processTicksAndRejections (internal/process/task_queues.js:86:5)","timestamp":"2019-12-09T14:36:24.176Z"}

Reproducible with: 2.2.0, 2.2.1

Notes:
- The error often appears in the logs when the Hub throws "Unity is already in the list. You cannot locate the same version"
- The error also often appears when users are saying that for one or another reason they are unable to open the projects

WORKAROUND:
use Command Prompt or Terminal to open Unity with command line argument -projectPath:
"<path to Unity.exe>" -projectPath "<path to the main project directory>"

Comments (13)

  1. bome99

    Aug 08, 2022 16:14

    still an issue

  2. Pawciu

    Mar 25, 2021 22:18

    Still not working

  3. Lylek

    Feb 09, 2021 19:20

    Issue still persists. Hub 2.4.2. Disabling my recently enabled ethernet cable prompted the hub to request that I reactivate my license, which solved the issue.

  4. vpsdss

    Aug 12, 2020 09:36

    Not working(

  5. ObvSoft

    Aug 10, 2020 09:27

    Hello, on August 10th 2020, I am using Unity Hub 2.3.2 and Unity 2019.3.15.f1 with a personal license and I confirm that the issue is still present.
    I have to open directly the scene of my projects as workaround.
    Maybe I can open a new bug ticket ?

  6. Akamis

    Jun 16, 2020 12:38

    It's not fixed !!
    I continue to have this issue.

  7. fherbst

    May 05, 2020 12:46

    The fix for me was to re-enable the ethernet adapter. I'm on a laptop with separate Wifi and Ethernet adapters, but disabling Ethernet broke Unity hub despite it not being used at all (purely on Wifi). Re-enabling the Ethernet adapter fixed the issue. Reported as Case 1244367

  8. eric-taylor

    Apr 26, 2020 16:17

    Still experiencing this issue as well.

  9. kodogijo

    Apr 21, 2020 06:32

    Fixed?
    Still not working with unity hub 2.3.0 and Unity 2019.3.10f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.