Search Issue Tracker

Fixed in 2021.1.X

Fixed in 2020.2.X

Votes

22

Found in

2018.4

2020.2.0b5

2021.1

Issue ID

1282801

Regression

No

The 'Mute' transition flag in the Sub-State Machine gets ignored after switching muted transitions

Animation

-

How to reproduce:
1. Open the attached '1282801.zip' project and open the 'Test' Scene
2. Open the Animator window ( Window > Animation > Animator)
3. In the Hierarchy window select 'AnimatedCube'
4. In the Animator window open the Parameters view
5. In the main section of the Animator window double-click on 'New StateMachine'
6. Disable 'Auto Live Link' and enter the Play mode
7. In the Parameters view enable 'MyTrigger' and observe the Animator window
8. Exit the Play mode
9. Unmute the transition between the 'Entry' and 'Left' states
10. Mute the transition between the 'Entry' and 'Up' states
11. Enter the Play mode and enable 'MyTrigger'

Expected result: The muted transition doesn't get executed
Actual result: The muted transition gets executed

Reproducible with: 2018.4.28f1, 2019.4.13f1, 2020.1.10f1, 2020.2.0b8, 2021.1.0a1

Note:
-reproducing this issue is not always consistent, sometimes it works as intended

  1. Response avatar

    Resolution Note (fix version 2021.1):

    Fixed in 2021.1.0a6

  2. Response avatar

    Resolution Note (fix version 2020.2):

    Fixed in 2020.2.0f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.