Search Issue Tracker

Fixed in Unity 2018.2

Votes

10

Found in

2018.1.0f2

Issue ID

1038153

Regression

Yes

Selecting custom MenuItem from Component tab results in "can't be checked because doesn't exist" error message

Editor - Other

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 4Minor or cosmetic issue

How to reproduce:
1. Open the attached "1038153_repro.zip" project
2. In the main menu, select Component/Component lister

Expected result: "ComponentList" window is opened without error messages.
Actual result: "ComponentList" window is opened, but with a console error message "Menu Component/Component lister can't be checked because doesn't exist".

Reproducible with - 2018.1.2f1, 2018.2.0b5
Not reproducible with - 2017.4.3f1, 2018.1.0b11, 2018.2.0a2

Notes:
- The issue does not seem to reproduce when custom MenuItem is created on the main menu tabs, other than "Component".
- The issue is reproducible only when selecting the Component/Component lister for the first time. Subsequent attempts result in the expected behavior.
- If the issue does not reproduce from the first attempt, press "Clear" in the Console window and repeat step 2.
- The issue occurs again after script recompile.

Fixed in 2018.3.0a11
Backported to 2018.2.13f1

Comments (11)

  1. 5e067a04c68b558374b486e8e079fd2c?d=mm

    Hukha

    Sep 24, 2018 13:04

    On Unity 2018.2.9, Still not solved. But work

  2. Ec513b1c9e49522f4697b45e415289c0?d=mm

    Wilbert-Blom

    Sep 04, 2018 09:19

    Unity 2018.2.6: still not resolved!

  3. D08ed1102a970944e9252d105ba9ff72?d=mm

    Noss1325

    Aug 23, 2018 11:59

    Still present on Unity 2018.2.5f1.

    Adamgoodrich, what a shame! Sorry to hear that. (not the right place to say this, but man keep up the hard work! You are making the best plugins ever!)

  4. 7bb6075e48ae066ea8418589d1633931?d=mm

    Julien-Lynge

    Aug 14, 2018 17:50

    Still an issue in 2018.2.3f1. Happens with a few of our libraries (like iTween, Obi) so we get a dozen errors in the console semi-randomly.

    I just tried JIMTHEGRIM's manual solution, and it _does_ work - but then you create more menus on the top bar for your various libraries, rather than having them hidden away in the Component menu like they were previously.

  5. A72985a7d6dd029c03e832b5d96a7a2f?d=mm

    pixelR

    Aug 10, 2018 08:36

    Or the Script Update API could just handle this use case and fix it when the old way of doing it outdated. :P

  6. 6822b53c1ccdb637044290870cec4b4f?d=mm

    jimthegrim

    Jul 26, 2018 14:08

    ahh k. so it just looks like the component bit of that particular file path is no longer used and some assets just haven't updated to reflect this yet. in my case it was Obi Ropes, so I just manually opened the custom editor file it was complaining about, and then removed the "Component/" bit from the MenuItem string.

    So yeah, just remove the part that says Component/ in whatever file its erroring on. :D

    Example:

    Bugged Code:
    [MenuItem("Component/Physics/Obi/Obi Particle Renderer",false,0)]

    Fixed Code:
    [MenuItem("Physics/Obi/Obi Particle Renderer",false,0)]

    ...then all you have to do is complain about it to your favorite asset dev so that they can get a fix out for their next update. :P

  7. 6822b53c1ccdb637044290870cec4b4f?d=mm

    jimthegrim

    Jul 26, 2018 12:09

    For the love of god.....please make this horrible issue go away... (-.-)

  8. 37a45125ea3144c385eae1aeb92db0ce?d=mm

    paulatwarp

    Jul 17, 2018 16:17

    I'm also getting this on plugins for my target platform. My workaround is to rename the menu to another menu.

  9. A72985a7d6dd029c03e832b5d96a7a2f?d=mm

    pixelR

    Jul 14, 2018 12:51

    Still happening in Unity 2018.2.0f and it's getting to be really nerve-wrecking to have the console littered with errors this way. This one should be fixed ASAP.

  10. Df325b5d166fd4d0d9207bbff1d48fb3?d=mm

    AdamGoodrich

    Jul 13, 2018 07:23

    We are getting a lot of complaints about this with CTS. Works on previous 5.x and 2017.x and not on 2018.x, and people just assume that our product is at fault.

    Can't seem to find a fix or work around for this anywhere!

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.