Search Issue Tracker

Won't Fix

Votes

1

Found in

2019.2.21f1

Issue ID

1222377

Regression

Yes

Rider package is not loaded until there are compilation errors in Assets

Scripting

-

Steps:

Prerequisites:
Open any version of Unity Editor and set "Preferences -> External Tools" to Rider

Open attached project (was created in 2018.4 Unity version)
==> There is an compilation error
==> Rider package is not loaded (You cannot open Rider by double-click on the error message in Console and Preferences looks like in attached snapshot)

NOT repro in 2019.1.14f1 (148b5891095a)
REPRO in 2019.2.21f1 (9d528d026557)
NOT repro in 2019.3.3f1 (7ceaae5f7503)
NOT repro in 2020.2.0a1.97 (e59ab5a2653b)

Note:
Fixing the compilation error or reopening project - fix the issue.
As well as removing Library before opening the project

  1. Response avatar

    Resolution Note (fix version ):

    As per the description this is only a problem in 2019.2.21.f1, and we have stopped support for this. In this case the user would have to upgrade his/her project to 2019.3.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.