Search Issue Tracker

Not Reproducible



Found in [Package]


Issue ID




Post Processing shader error Kernal MultiScaleVODownsample1 not found in built player

Package: PostProcessing


Post Processing shader error when running scenes loaded from a Player or Asset Bundles.

To reproduce:
1. Open attached project
2. Build Asset Bundles via: "Window > Asset Management > Addressable Assets"
2.a. Click "Build > Build Player Content"
3. Build & Run the player with via: "File > Build Settings..."
3.a. Check "Development Build"
3.b. Click "Build And Run" button.
4. In running player, open scene using the UI buttons
4.a. "LoadSceneMode.Single" loads the scene from Player Data
4.b. "Addressable.LoadSceneMode.Single" loads the scene from Asset Bundles
5. Notice errors in development console.

I tried reproducing this error in a smaller project setup but was unable to do so, not sure what is so specific in this project as to why the shaders are not being built correctly.

Comments (7)

  1. Chaeck

    Nov 02, 2023 13:39

    I solved it using YAOWENDEV's method.


    Jul 28, 2023 13:38

    Hello everybody!

    I solved it Switching to the WebGL platform and compiling from a scene that doens't have post processing. In my case was the main menu.

    I home this helps

  3. YaowenDev

    May 07, 2022 16:38

    Aside from things like deleting the Library folder and re-import all assets, enabling Auto Graphics API (Project Setting - Player - Other settings - Rendering) on Android fixes the issue in my case.

  4. HernandoNJ

    Feb 10, 2022 00:17

    Check out the answer from "dbdenny" in this forum

  5. Chris_Payne_QS

    Oct 26, 2021 02:12

    I'm also getting this on a Nintendo Switch development build - completely floods the debug output and makes the game unplayable and unprofilable. Unity 2018.4.32f1

  6. adnanxyousuf

    Sep 29, 2021 11:31

    I got the same error, when I open my Windows Build Project Files to Linux. It fixed by changing the target platform to Linux on build settings! See if it helps.

  7. virdys

    Jan 12, 2021 15:54

    Same issue with Unity 2018.4.30 and post processing package version 3.0.1.

    This issue appears after a single switch platform on android.

    I must remove and re-install the post processing package before each window compilation to avoid this shader error on runtime.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.