Search Issue Tracker

Active

Votes

0

Found in

2017.4

2018.4

2019.2

2019.3

2020.1

2020.1.0a18

Issue ID

1208939

Regression

No

[Perforce] Assets with Unicode characters in their file name cannot be added/submitted to Perforce

Version Control

-

How to reproduce:
1. Create a new project in your preferred workspace and open it
2. Connect it to Perforce and disable "Automatic Add"
3. Create a new material, add it and submit it
4. Change its name to "Ä", observe that the material is now gone from the Project Window (Refocus the Editor to make the asset reappear)
5. Try to add and submit the renamed asset
6. Observe the error

Expected result: assets using Unicode characters appear in the Project Window right away after getting renamed and they are addable/submittable to Perforce
Actual result: assets using Unicode characters disappear from the Project Window upon getting renamed and can't be added/submitted to Perforce correctly

Reproduced in: 2020.1.0a18, 2019.3.0f4, 2019.2.16f1, 2018.4.15f1, 2017.4.36f1

Notes:
- If you were to rename assets in the File Explorer and submitted them through P4V that would work just fine. The Editor seems to be adding files incorrectly and files that were renamed/added in the Editor won't be submittable through the CL/P4V as well.
- Plastic SCM seems to handle Unicode characters just fine in the Editor

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.