Search Issue Tracker

Fixed in 2021.1.X

Fixed in 2019.4.X, 2020.1.X, 2020.2.X



Found in




Issue ID




Package Manager fails to download LFS files from Git repository when the Git URL contains a path extension



How to reproduce:
1. Make sure that Git and Git LFS are installed
2. Open the attached "1256330 repro" project
3. Open the Packages > lfs_test > Editor folder

Expected result: the "NewImage.png" Asset is downloaded
Actual result: the "NewImage.png" Asset isn't downloaded and it only contains the metadata about the file

Reproducible with: 2019.4.4f1, 2020.1.0b16, 2020.2.0a18
Could not test with: 2018.4.24f1 (no support for Git URLs)

-Changing the Git URL ending from "My_LFS_Package2.git?path=/Case2" to "My_LFS_Package.git" solves the issue and the LFS files are downloaded successfully

  1. Resolution Note (fix version 2021.1):

    Fixed in 2021.1.0a1

  2. Resolution Note (fix version 2020.2):

    Fixed in 2020.2.0b8

  3. Resolution Note (fix version 2020.1):

    Fixed in 2020.1.10f1

  4. Resolution Note (fix version 2019.4):

    Fixed in 2019.4.13f1

Comments (5)

  1. thefallengamesstudio

    Feb 13, 2023 21:45

    Thanks! You saved the day, sir!

    Confirmed on 2021.3.18f1

    Hope this gets fixed soon

  2. litteBugHunter

    Jan 20, 2023 15:26

    I encountered this issue today in Version 2021.3.16f1.
    I fixed it by putting my .gitattributes file next to the package.json file. Apparently the package manager only pulls from lfs if the .gitattributes file is present

  3. guneyozsan

    Nov 08, 2022 09:50

    Still observed in 2021.3.7f1

  4. yakandco

    Aug 27, 2021 06:29

    Yup I just hit this issue in 2020.3.14, hadn't tried 2020.3.16 yet ^ but saw that comment above, saves me from bothering to try.

  5. unity_xquSE-bFhAdmCg

    Aug 25, 2021 09:56

    Not fixed in 2020.3.16f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.