Search Issue Tracker

Fixed in 2022.2.X

Planned for 2022.1.X

Votes

0

Found in

2021.2.0a13

2021.2.1f1

2022.1

Issue ID

1379745

Regression

Yes

Only one 'Compressed in memory' AudioClip is playable in WebGL Player

Web Platform

-

How to reproduce:
1. Open the user’s attached “AudioBug_.zip” project
2. Open the “SampleScene” Scene
3. Switch to WebGL platform
4. Build And Run
5. In the WebGL Player press “A”, “S”, “D” buttons on the keyboard

Expected result: 3 different Audio Clips are played
Actual result: Only the first Audio Clip played can be played

Reproducible with: 2021.2.0a13, 2021.2.6f1, 2022.1.0b2
Not reproducible with: 2019.4.33f1, 2020.3.24f1, 2021.2.0a12

Notes:
- The expected result can be observed in the Play Mode
- This issue is not reproducible if Audio Clip in the Import Settings has Load Type as “Decompress On Load”
- Tested on Mac

  1. Response avatar

    Resolution Note (fix version 2022.2):

    Fixed in 2022.2.0a4

Comments (1)

  1. 020435c7f57747398c615eb63734c819?d=mm

    Scott-Elson

    Feb 03, 2022 15:51

    At least in 2021.2.9 and .10 using "Compressed in Memory" is a problem as well. This happened sometime after 2021.1.12. If you play a sound that lasts for a few seconds the next time you try to play a different sound the previous sound will play instead, even if you're in a completely different scene and all the audiosource and audioclips are gone. There were other issues as well related to trying to stop sounds which also went away when changing the compression.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.