Search Issue Tracker

Fixed in 2017.1.X



Found in


Issue ID




Multiple "Dynamic batching: index buffer source is NULL" errors because of procedurally generated mesh

Graphics - General


Steps to reproduce:

1. Open attached project
2. Open and play scene "Scene0"
3. Notice console flooded with: "Dynamic batching: index buffer source is NULL..." erorrs

Note: in 5.3.5f1 the error was "srcIB"

Reproduced with: 5.3.6p1, 5.4.0f3, 5.5.0a5

Comments (30)

  1. RunningJack

    Nov 08, 2016 21:19

    Same issue here. Fixed it by removing the material from empty subMeshes

  2. Venryx

    Oct 25, 2016 10:11

    For me the problem was that one of the models had a material in the materials list that had no faces using it. Removing the unused materials fixed the error.

  3. ikefrc

    Oct 20, 2016 22:29

    same problem, any news on this?

  4. Radneto

    Oct 12, 2016 10:59

    We've recently switched to Unity 5.4.1p2 and our game now repeatedly crashes to desktop on iOS with il2cpp enabled.

  5. livingtarget

    Oct 12, 2016 10:57

    Crashes iOS to home screen with il2cpp enabled after switching to 5.4.

  6. minhngyen

    Oct 05, 2016 21:07

    Started getting this error after upgrading to 5.4.1f1. Looked like it was happening when I was setting a second set of triangles with an empty buffer. Patched up my code but don't think this was throwing an error in previous versions?

  7. Khal-Shariff

    Aug 15, 2016 22:13

    I get the same error, and we're using Simple LOD and I edited a mesh in game with a simple mesh editor.. had to turn dynamic batching off!

  8. Metricton

    Aug 13, 2016 20:36

    Seems to be an issue with sub meshes, when there are more than one triangle lists on dynamically generated meshes. If I leave sub meshes at 2 but only add one of my triangle lists it works fine. However, when I add the second set of triangles it spews forth this error non stop. Also, each sub mesh has a different material. This is in the latest version of 5.4 as well.

  9. Font8

    Aug 09, 2016 00:48

    Fills my console with spam in 5.4, makes dynamic batching unusable!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.