Search Issue Tracker

Fixed in 2017.1.X



Found in


Issue ID




Multiple "Dynamic batching: index buffer source is NULL" errors because of procedurally generated mesh

Graphics - General


Steps to reproduce:

1. Open attached project
2. Open and play scene "Scene0"
3. Notice console flooded with: "Dynamic batching: index buffer source is NULL..." erorrs

Note: in 5.3.5f1 the error was "srcIB"

Reproduced with: 5.3.6p1, 5.4.0f3, 5.5.0a5

Comments (30)

  1. S37H

    Apr 11, 2017 00:58

    In my case, this was caused by using a sprite that was 100% transparent. I added a single pixel, even at 1% transparency and it fixed it.

  2. RobG88

    Apr 09, 2017 00:30

    I'm having experiencing the same error with the Jelly Garden Match 3 store asset (!/content/43260) when reskinning the standard assets with my own art.

    For everyone's information - hopefully this maybe helpful to some - I installed the Unity 5.5 2D EXPERIMENTAL PREVIEW RELEASE 3 ( and did not encounter these errors after reskinning.

  3. necio

    Apr 08, 2017 18:50

    Just updated my project to 5.6 and got this errors too.

  4. Hanh

    Apr 08, 2017 03:44

    I have the this problem starting with 5.6

  5. fazhom

    Apr 06, 2017 07:47

    I have the same problem starting with 5.6 (5.5.3 was ok).
    For me, the problem is caused by the Animator of game object: the animation is a sprite sheet. If I decactivate the Animator, it's ok (but then, I don't have my cartoon explosion animation)
    I have several type of explosions of those on various game objects and the problem does NOT occur for every one...

  6. Acreates

    Feb 24, 2017 22:52

    Fixed it. It was an LOD mesh. Had to turn off parents until the spam stopped occurring. Then isolated the problem. Seems that LOD systems are very cumbersome in Unity.

  7. Elthari0n

    Jan 05, 2017 14:23

    It seems like the error lies around empty SubMeshes and its MeshRenderers. If you assign a Material in the SharedMaterials Array of any MeshRender, this error occures as long as that particular Material is used by any other SubMesh.

  8. tessellation

    Nov 30, 2016 06:04

    I'm not noticing any visual problems other than the error message. I am definitely using multiple materials/sub-meshes and procedural meshes with degenerate triangles to avoid array reallocations. Happens in latest 5.5.0f3

  9. livingtarget

    Nov 24, 2016 13:12

    5.4.3p1 seems to contain a fix that could be related? "Fixed a crash when using dynamic batching". Also likely to be completely unrelated.

  10. Twelv445

    Nov 15, 2016 19:44

    Am also experiencing this on 5.4.2f2 - I cant say the exact source of the issue but I am also using SimpleLOD to edit meshes so thus have procedural geometry in my scene like other people have who have reported the bug have also been using.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.