Search Issue Tracker

Fixed in 5.3.0

Votes

33

Found in

4.3.1f1

Issue ID

584500

Regression

No

MonoDevelop fails to fully open from within Unity

CodeEditors

-

When the JavaScript script file is double-clicked in Unity editor for the first time after restarting computer, MonoDevelop fails to fully load and an error pop-up message similar to this is shown:

Error while trying to load the project 'C:\Users\Public\Documents\Unity Projects\4-3.3f1_AngryBots\Assembly-CSharp-firstpass.csproj': Object reference not set to an instance of an object.

Reproduced with:
Unity Version 4.3.1f1 (cebd4d9b5122)
Unity Version 4.3.3f1 (c8ca9b6b9936)

Comments (14)

  1. B957022c7ad50a71d550bcad14935f61?d=mm

    HubertRonald

    Sep 23, 2017 13:26

    Thank you JESUSLUVSYOOH your suggestion works for me !

  2. 358c07c573ce64927f84875e939d1ba7?d=mm

    uncleGe

    Apr 12, 2016 18:10

    Yup, JESUSLUVSYOOH's solution (on previous page) fixed me right up!

  3. Ccb8f9419f592b2289d20716a7e26399?d=mm

    mkondor

    Feb 19, 2016 15:00

    Created a new project, first time to open the first script I created got this error (Unity v5.3.2f1)

  4. 4f5458213e419a9e6a90599e99dea1bf?d=mm

    abstractfragment

    Jan 11, 2016 19:15

    Jesus' solution did not work for me :c. It's already selected and booting Monodevelop on its own also fails.

  5. 62b222454ef9a91fb912e4c2e7fbaa0d?d=mm

    Ozgar

    Dec 09, 2015 04:04

    I upgraded to 5.3 and now this issue has started for me.

  6. D69a598a6e501fd46fde83a5af1bae61?d=mm

    Cachimery

    Nov 13, 2015 18:29

    The solution of JESUSLUVSYOOH works for me, thanks.

  7. 207ca65ec40167723e41c99f9ad77dc0?d=mm

    Keg85

    Jun 29, 2015 09:27

    I also have this issue, but tried JESUSLUVSYOOH's solution has not worked for me as Monodevelop is already selected.

    It is only after the computer is restarted once I close the message and restart Unity and click the script it works fine again until reboot.

  8. Fb19cc3ea0bd0aaaa95433edb6955c71?d=mm

    zeeshancan

    Jun 23, 2015 15:57

    how do you reproduce it. please explain it in brief

  9. E298e37d465695166d7451e07cc21ce2?d=mm

    BlackPanda

    Mar 27, 2015 05:17

    Wow! That's one good solution. It worked for me! Still, Unity guys should solve this bug.

  10. 13e5f8b1ea7a5f84cd73328edfc6afe0?d=mm

    amarnaman

    Oct 16, 2014 09:52

    Well, who'd have believed it, Jesus really does save (at least when it comes to Unity issues). I was sceptical but it worked for me. Just follow the steps and select your MonoDevelop.exe (wherever it may be) and then restart Unity (and MonoDevelop). No repeat occurrence of the problem!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.