Search Issue Tracker

Won't Fix



Found in


Issue ID




[Mac][.NET 4.6] "System.Net.WebException" error in .NET 4.6



Reproduction steps:

1. Open "Security DLL not" project
2. Enter Play mode
3. See the Console window output (Error)
4. Change the Scripting Runtime API to 3.5
5. Enter Play mode
6. See that there are no errors in the Console window

Expected Result: No errors should appear in both API's
Actual Result: Using .NET 4.6 results in an error

Reproduced with: 2017.3.0a7, 2017.2.0b11, 2017.1.1p2

Error(2017.3.0a7, 2017.2.0b11): "System.Net.WebException: Error: SecureChannelFailure (Security) ---> System.DllNotFoundException"
Error(2017.1.1p2): "System.Net.WebException Error: TrustFailure (the authentication or decryption has failed.) ---> System.IO.IOException"

Comments (1)

  1. Airat1995

    Feb 20, 2018 07:51

    I reproduced this error, when I tried to use HttpClient with .NET 4.6. Also work only when I tried to send request to secured connection (https) with http on the local server fine.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.