Search Issue Tracker

Fixed in 12.0.0

Votes

76

Found in [Package]

6.7.0

Issue ID

1149057

Regression

No

[URP] VFX Graph projects have visual artifacts when viewed with certain mobile GPUs

Package: Visual Effect Graph

-

Team notes:
- VFX Graph not production ready on mobile, aim to address during 2020 cycle.
- More info on forums: https://forum.unity.com/threads/effects-created-using-vfx-graph-not-showing-on-android.841465

Repro steps:
1. Create a default VFX Graph
2. Drag it in the scene
3. Build the project for Android
4. Launch the project on the phone
5. Depending on the phone, severe visual artifacts can be visible (images attached).

Notes:
- Visual artifacts on Moto G5s Plus (Adreno 506)
- Works fine on Samsung S9 (Adreno 630)

  1. Resolution Note (fix version 12.0.0):

    Fixed in 2022.1.0a12. Verified on Samsung Galaxy Fold 2. Thank you all for following this issue. The VFX Graph is not out of preview for mobile and our aim is to address this during the 2020 cycle. This will include looking into mobile issues such as this one, as well as a further focus on URP integration, including lit shaders.

    We will temporarily close this issue with a 'postpone' tag to manage expectations that there won't be an imminent resolution and that work on this will come as part of a bigger mobile push for the VFX Graph throughout this year. Please rest assured that the issue is very much on our radar and will be looked into by out team.

    Stay healthy and safe!

Comments (35)

  1. Swordancer

    Dec 26, 2019 17:50

    It works on Snapdragon 855 with the latest version now. Still problems on Snapdragon 636 and 625.

  2. AvgTom

    Dec 11, 2019 11:53

    When we deploy the example system (simple particle system - looks like a sun) VFX to the Oculus Quest, all the particles become what seems to be, infinetly long lines. They appear to move correctly, just incorrect graphicall representation.

  3. hellowill89

    Dec 08, 2019 19:38

    Same here. Continues to be an issue. This is with Xiaomi Mi Mix (Adreno GPU)

  4. danny_unity495

    Nov 18, 2019 19:57

    Same here on Quest. Anyone have a temp workaround?

  5. LudwigVRtualX

    Nov 01, 2019 10:01

    Same Issue on Oculus Quest

  6. Swordancer

    Oct 13, 2019 06:46

    I have the same problem even with Snapdragon 855. It looks like it doesn't work with the most Android devices.

  7. NTG-SAnderson

    Sep 20, 2019 17:49

    We're also experiencing this issue on Pixel 2 (Regular). This is a game breaking issue and needs to be elevated ASAP.

  8. Swordancer

    Sep 08, 2019 09:31

    Same here, still not working even on latest beta. LWRP Visual Graphs just do not work on some devices with Ardeno GPU's. It's quite some this since it was reported and still no solutiuon?

  9. dansopanso

    Aug 02, 2019 10:30

    Same issue on LG G6 (Adreno 530)
    And on Samsung Galaxy Tablet s5e (adreno 615)

  10. Loic_LEMIERE

    Jul 24, 2019 11:50

    Same issue here with the vive focus... gives me a line of particules (instead of one) for every computed particle... , never happens in the editor though...

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.